sapconf: tuned.utils.commands: Writing to file /sys/block/.../queue/scheduler error: [Errno 22] Invalid argument

This document (7024298) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 12 Service Pack 3 (SLES 12 SP3)
SUSE Linux Enterprise Server 12 Service Pack 4 (SLES 12 SP4)
SUSE Linux Enterprise Server 12 Service Pack 5 (SLES 12 SP5)
SUSE Linux Enterprise Server 15 (SLES 15)
SUSE Linux Enterprise Server 15 Service Pack 1 (SLES 15 SP1)
SUSE Linux Enterprise Server 15 Service Pack 2 (SLES 15 SP2)
SUSE Linux Enterprise Server for SAP Applications 12 Service Pack 3
SUSE Linux Enterprise Server for SAP Applications 12 Service Pack 4
SUSE Linux Enterprise Server for SAP Applications 12 Service Pack 5
SUSE Linux Enterprise Server for SAP Applications 15
SUSE Linux Enterprise Server for SAP Applications 15 Service Pack 1
SUSE Linux Enterprise Server for SAP Applications 15 Service Pack 2

Situation

The file /var/log/tuned/tuned.log contains a warning like:
 
ERROR    tuned.utils.commands: Writing to file /sys/block/sdb/queue/scheduler error: [Errno 22] Invalid argument

Resolution

To avoid a complex manual tuned reconfiguration, please update to sapconf 5.

Sapconf 5 does not rely and tuned and sets the IO scheduler by itself.  In the default configuration both schedulers "noop" and "none" are tried.

On update the current tuned configuration will be transferred to the sapconf configuration file.
Please read the man page sapconf(5) for details.


 

Cause

Devices can either support non-multiqueue schedulers (like noop, deadline, cfq) or multiqueue schedulers (like none, mq-deadline, bfq, kyber).
Sapconf before version 4 relies on tuned, which can set only one scheduler per disk section.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7024298
  • Creation Date: 29-Nov-2019
  • Modified Date:06-Aug-2020
    • SUSE Linux Enterprise Server
    • SUSE Linux Enterprise Server for SAP Applications

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center