SUSE Support

Here When You Need Us

Run Oracle Database by Pacemaker

This document (7024303) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise High Availability Extension 12
SUSE Linux Enterprise High Availability Extension 15

Situation

When adding Oracle Database to cluster configuration "Pacemaker" the following errors could be reported in system's log: 

WARNING: Unable to login as "C##OCFMON", using "sysdba" user instead 
ERROR: monprofile must start with C## for container databases

which result in Oracle Listener and Oracle Database resource agents failing to startup. 

Resolution

To avoid above errors, Oracle resource need to be configured with following two options:

monuser="C##OCFMON" monprofile="C##MONPROFIL"

Cause

Oracle Monitor user is not being created correctly for being used in Oracle Container Database. Also, monitor user's profile need to start with C## for container database. Not defining monprofile parameter will fallback to default value. 

Additional Information

Oracle Resource Agent will create monitor user as well monitor profile if they are not exists. Keeping them to default values doesn't work with new Oracle Multitenant "Container" Database. 

Default values are: 
monuser : "OCFMON"
monprofile : "OCFMONPROFILE"

So, pacemaker configuration should looks like following: 

primitive lsn-oracle oralsnr \
params sid=orcl 
primitive oracle-db oracle \
params sid=orcl home="/opt/oracle/SW/database" user=oracle monuser="C##OCFMON" monprofile="C##MONPROFIL" 

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7024303
  • Creation Date: 02-Dec-2019
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise High Availability Extension

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.