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Linux NFS client vs NETAPP - client hang - server not responding

This document (7024103) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 Service Pack 1
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server 12 Service Pack 5
SUSE Linux Enterprise Server 12 Service Pack 4
NETAPP ONTAP < 9.1P15

Situation

SLES NFS client hangs. NETAPP NFS server is ONTAP Version < 9.1P15. The system log on Linux nfs clients reports:

nfs: server <name> not responding

Kernel is >= 4.11 which matches SLES 12 SP4 and later. There was no issue with SLES 12 SP3 or prior e.g. kernel < 4.11.

NOTE:  There are many causes of nfs server "not responding" messages.  This document only covers one cause.

Resolution

Update of NETAPP to ONTAP version >= 9.1P15 is needed. There is no workaround on the Linux side.

Cause

This is an incompatibility between NETAPP ONTAP < 9.1P15 and kernel >= 4.11, because of NFS-related fixes in the Linux kernel.

For more information, see NetApp Bug 1127148, which is reported to be titled (this information is unconfirmed by SUSE):

"ONTAP Fails to Recover from Going Zero Window After Shrinking Right Edge for a Linux client".

The following link should provide details, but will likely require a NetApp account to view.

https://mysupport.netapp.com/site/bugs-online/product/ONTAP/BURT/1127148

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7024103
  • Creation Date: 06-Sep-2019
  • Modified Date:30-Mar-2021
    • SUSE Linux Enterprise Server

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