SUSE Support

Here When You Need Us

Assigning GPU to a KVM guest can cause the host to crash

This document (7023948) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15

Situation

When adding a VGA controller to a KVM Guest, on boot up of the guest the KVM host server crashes with messages similar to the following excerpts:

[  442.824989] WARNING: CPU: XX PID: XXXX at ../drivers/gpu/drm/drm_mode_config.c:444 drm_mode_config_cleanup+0x268/0x2c0 [drm]
 ...
[  442.966571] RIP: 0010:drm_mode_config_cleanup+0x268/0x2c0 [drm]
 ...
[  443.183097] [drm:drm_mode_config_cleanup [drm]] *ERROR* connector VGA-1 leaked!
 ...
[  443.431143] Memory manager not clean during takedown.
[  443.431151] ------------[ cut here ]------------
[  443.431159] WARNING: CPU: 11 PID: 3967 at ../drivers/gpu/drm/drm_mm.c:946 drm_mm_takedown+0x20/0x30 [drm]


Resolution

Remove the assigned GPU device from the guest KVM.

Cause

This is a known limitation with the DRM code (Direct Rendering Manager).

Additional Information

PCI devices can be added to a KVM Guest to increase the Guest's performance.  When the PCI device is a GPU and the Host is in graphical mode, the Host can crash when the Guest is started. DRM drivers can Oops during dynamic unbinding which is done when the Host tries to give the GPU device to the guest.

Since panic_on_oops is set in SLES 15 SP1, this will cause the Host to crash.

This issue exists for multiple GPU cards running on multiple platforms.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7023948
  • Creation Date: 17-Jun-2019
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.