SSSD could not restart critical service [pac]

This document (7018621) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server 12 SP1

Situation

Running a IPA (Identity, Policy, and Audit)server based on RedHat 7.x IDM and adding SLES 12 SP2 servers systems as clients results in the following error.

---
pmms-puppet-05 sssd_be[4468]: GSSAPI client step 2
pmms-puppet-05 sssd[4469]: Starting up
pmms-puppet-05 sssd[4471]: Starting up
pmms-puppet-05 sssd[4472]: Starting up
pmms-puppet-05 sssd[4470]: Starting up
pmms-puppet-05 sssd[4467]: Exiting the SSSD. Could not restart critical service [pac].
pmms-puppet-05 systemd[1]: sssd.service: Control process exited, code=exited status=1
pmms-puppet-05 systemd[1]: Failed to start System Security Services Daemon.
pmms-puppet-05 systemd[1]: sssd.service: Unit entered failed state.
pmms-puppet-05 systemd[1]: sssd.service: Failed with result 'exit-code'
---

Resolution

Install the "sssd-ad" package e.g. via zypper:

zypper in sssd-ad

Cause

The error

---
Exiting the SSSD. Could not restart critical service [pac].
---


is caused by a missing dependency to also install the package "sssd-ad" as this will make the PAC executable available.

Additional Information

Additional information on FreeIPA client installation:

https://en.opensuse.org/Portal:FreeIPA/Installation

More information about FreeIPA in general:

https://www.freeipa.org/page/Main_Page

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7018621
  • Creation Date: 15-Feb-2017
  • Modified Date:23-Feb-2021
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center