SUSE Support

Here When You Need Us

Configuring network in SLE12 rescue mode

This document (7017954) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12 Service Pack 1 (SLES 12 SP1)


Situation

A SLES12 server has been booted into rescue mode and chrooted into the installed system having rebound /proc, /sys and /dev to the chrooted environment. The following attempts to start the network fail.

Rescue:/ # systemctl start network.service
Running in chroot, ignoring request.

Rescue:/ # rcnetwork start
rcnetwork: no such service network


Resolution

You must configure the network manually. If you did not chroot the installed system, the dhclient command may not be available in rescue mode. If so, use the manual method described below.

DHCP Method
If you use DHCP, use the dhclient command to get a DHCP address from the network.

Example:
dhclient eth0

This will configure DHCP on the interface specified, in this case eth0.

-OR-

Manual Method
If you don't use DHCP, you must manually configure the IP and default route.

  1. Use the ifconfig command to configure the net device.
    ifconfig eth0 <ip address> netmask <netmask value>

    Example: 
    ifconfig eth0 xxx.xxx.xxx.xxx netmask xxx.xxx.xxx.xxx
    (Replace the x's in this example with a legitimate IP address and mask.)

  2. Use the route command to configure a communication route.
    route add default gw <route value> dev <network interface>

    Example:
    route add default gw xxx.xxx.xxx.xxx dev eth0
    (Replace the x's in this example with a legitimate route.)

Cause

The SLES12 rescue system boots up with SystemV init, not systemd. The chroot environment services on the installed system are therefore incompatible.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7017954
  • Creation Date: 16-Aug-2016
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.