SUSE Support

Here When You Need Us

Installing with local install media and a network autoyast file fails

This document (7017325) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 12 Service Pack 1 (SLES 12 SP1)
SUSE Linux Enterprise Server 12


Situation

An autoyast installation fails to find the autoyast control file with the following error:

"An error occurred while fetching the profile: Cannot find URL 'http://config.server.com/autoinst.xml' via protocol HTTP(S). Server returned code 0."

The autoyast control file is on the network, while the installation media is on DVD. If you use a network install source, the same autoyast control file works fine.

The following Installation Boot Options fail:
install=cd:// autoyast=http://config.server.com/autoinst.xml dhcp=1

The following Installation Boot Options work:
install=http://installation.server.com/sles12sp1/ autoyast=http://config.server.com/autoinst.xml

The autoinstall process fails to query for a DHCP address. The ifconfig command shows only the local loopback interface and no other configured network interfaces.

Resolution

Use netsetup=dhcp instead of dhcp=1 on the Installation Boot Options line. For example,

change this:
install=cd:// autoyast=http://config.server.com/autoinst.xml dhcp=1

to this:
install=cd:// autoyast=http://config.server.com/autoinst.xml netsetup=dhcp

Cause

The autoyast dhcp=1 directive is no longer supported in SLES12. The dhcp=1 directive was deprecated in SLES11, but both netconfig=dhcp and dhcp=1 work for SLES11 and all its service packs.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7017325
  • Creation Date: 03-Mar-2016
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.