Upstream information

CVE-2023-26053 at MITRE

Description

Gradle is a build tool with a focus on build automation and support for multi-language development. This is a collision attack on long IDs (64bits) for PGP keys. Users of dependency verification in Gradle are vulnerable if they use long IDs for PGP keys in a `trusted-key` or `pgp` element in their dependency verification metadata file. The fix is to fail dependency verification if anything but a fingerprint is used in a trust element in dependency verification metadata. The problem is fixed in Gradle 8.0 and above. The problem is also patched in Gradle 6.9.4 and 7.6.1. As a workaround, use only full fingerprint IDs for `trusted-key` or `pgp` element in the metadata is a protection against this issue.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.6 6.4
Vector CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H
Attack Vector Network Network
Attack Complexity High High
Privileges Required High High
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1208824 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 gradle Not affected
SUSE Linux Enterprise Desktop 15 SP5 gradle Not affected
SUSE Linux Enterprise High Performance Computing 15 SP5 gradle Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP5 gradle Not affected
SUSE Linux Enterprise Real Time 15 SP3 gradle Not affected
SUSE Linux Enterprise Server 15 SP5 gradle Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 gradle Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 gradle Not affected
SUSE Manager Proxy 4.3 gradle Not affected
SUSE Manager Retail Branch Server 4.3 gradle Not affected
SUSE Manager Server 4.3 gradle Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 gradle Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 gradle Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS gradle Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS gradle Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 gradle Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS gradle Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS gradle Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 gradle Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS gradle Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 gradle Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 gradle Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP4 gradle Not affected
SUSE Linux Enterprise Server 15 SP2 gradle Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS gradle Not affected
SUSE Linux Enterprise Server 15 SP3 gradle Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS gradle Not affected
SUSE Linux Enterprise Server 15 SP4 gradle Not affected
SUSE Linux Enterprise Server 15 SP4-LTSS gradle Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 gradle Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 gradle Not affected
Products past their end of life and not receiving proactive updates anymore.
SUSE Enterprise Storage 7 gradle Not affected
SUSE Linux Enterprise Desktop 15 SP2 gradle Not affected
SUSE Linux Enterprise Desktop 15 SP3 gradle Not affected
SUSE Linux Enterprise Real Time 15 SP2 gradle Not affected
SUSE Linux Enterprise Real Time 15 SP4 gradle Not affected
SUSE Linux Enterprise Server 15 SP2-BCL gradle Not affected
SUSE Linux Enterprise Server 15 SP3-BCL gradle Not affected
SUSE Manager Proxy 4.1 gradle Not affected
SUSE Manager Proxy 4.2 gradle Not affected
SUSE Manager Retail Branch Server 4.1 gradle Not affected
SUSE Manager Retail Branch Server 4.2 gradle Not affected
SUSE Manager Server 4.1 gradle Not affected
SUSE Manager Server 4.2 gradle Not affected
Products at an unknown state of their lifecycle.
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS gradle Not affected


SUSE Timeline for this CVE

CVE page created: Thu Mar 2 07:00:07 2023
CVE page last modified: Fri Apr 19 14:41:38 2024