Upstream information

CVE-2022-43754 at MITRE

Description

An Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in spacewalk/Uyuni of SUSE Linux Enterprise Module for SUSE Manager Server 4.2, SUSE Linux Enterprise Module for SUSE Manager Server 4.3, SUSE Manager Server 4.2 allows remote attackers to embed Javascript code via /rhn/audit/scap/Search.do This issue affects: SUSE Linux Enterprise Module for SUSE Manager Server 4.2 hub-xmlrpc-api-0.7-150300.3.9.2, inter-server-sync-0.2.4-150300.8.25.2, locale-formula-0.3-150300.3.3.2, py27-compat-salt-3000.3-150300.7.7.26.2, python-urlgrabber-3.10.2.1py2_3-150300.3.3.2, spacecmd-4.2.20-150300.4.30.2, spacewalk-backend-4.2.25-150300.4.32.4, spacewalk-client-tools-4.2.21-150300.4.27.3, spacewalk-java-4.2.43-150300.3.48.2, spacewalk-utils-4.2.18-150300.3.21.2, spacewalk-web-4.2.30-150300.3.30.3, susemanager-4.2.38-150300.3.44.3, susemanager-doc-indexes-4.2-150300.12.36.3, susemanager-docs_en-4.2-150300.12.36.2, susemanager-schema-4.2.25-150300.3.30.3, susemanager-sls versions prior to 4.2.28. SUSE Linux Enterprise Module for SUSE Manager Server 4.3 spacewalk-java versions prior to 4.3.39. SUSE Manager Server 4.2 release-notes-susemanager versions prior to 4.2.10.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having low severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.4 3
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:N/A:N
Attack Vector Network Network
Attack Complexity Low High
Privileges Required Low Low
User Interaction Required Required
Scope Changed Changed
Confidentiality Impact Low Low
Integrity Impact Low None
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1204741 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES15-SP3-Manager-4-2-Proxy-BYOS-EC2-HVM
  • python3-spacewalk-client-tools >= 4.2.21-150300.4.27.3
  • spacewalk-backend >= 4.2.25-150300.4.32.4
  • spacewalk-base-minimal >= 4.2.30-150300.3.30.3
  • spacewalk-base-minimal-config >= 4.2.30-150300.3.30.3
  • spacewalk-client-tools >= 4.2.21-150300.4.27.3
Image SLES15-SP3-Manager-4-2-Server-BYOS-EC2-HVM
  • py27-compat-salt >= 3000.3-150300.7.7.26.2
  • python3-spacewalk-client-tools >= 4.2.21-150300.4.27.3
  • python3-urlgrabber >= 3.10.2.1py2_3-150300.3.3.2
  • spacecmd >= 4.2.20-150300.4.30.2
  • spacewalk-backend >= 4.2.25-150300.4.32.4
  • spacewalk-backend-app >= 4.2.25-150300.4.32.4
  • spacewalk-backend-applet >= 4.2.25-150300.4.32.4
  • spacewalk-backend-config-files >= 4.2.25-150300.4.32.4
  • spacewalk-backend-config-files-common >= 4.2.25-150300.4.32.4
  • spacewalk-backend-config-files-tool >= 4.2.25-150300.4.32.4
  • spacewalk-backend-iss >= 4.2.25-150300.4.32.4
  • spacewalk-backend-iss-export >= 4.2.25-150300.4.32.4
  • spacewalk-backend-package-push-server >= 4.2.25-150300.4.32.4
  • spacewalk-backend-server >= 4.2.25-150300.4.32.4
  • spacewalk-backend-sql >= 4.2.25-150300.4.32.4
  • spacewalk-backend-sql-postgresql >= 4.2.25-150300.4.32.4
  • spacewalk-backend-tools >= 4.2.25-150300.4.32.4
  • spacewalk-backend-xml-export-libs >= 4.2.25-150300.4.32.4
  • spacewalk-backend-xmlrpc >= 4.2.25-150300.4.32.4
  • spacewalk-base >= 4.2.30-150300.3.30.3
  • spacewalk-base-minimal >= 4.2.30-150300.3.30.3
  • spacewalk-base-minimal-config >= 4.2.30-150300.3.30.3
  • spacewalk-client-tools >= 4.2.21-150300.4.27.3
  • spacewalk-html >= 4.2.30-150300.3.30.3
  • spacewalk-java >= 4.2.43-150300.3.48.2
  • spacewalk-java-config >= 4.2.43-150300.3.48.2
  • spacewalk-java-lib >= 4.2.43-150300.3.48.2
  • spacewalk-java-postgresql >= 4.2.43-150300.3.48.2
  • spacewalk-taskomatic >= 4.2.43-150300.3.48.2
  • spacewalk-utils >= 4.2.18-150300.3.21.2
  • susemanager >= 4.2.38-150300.3.44.3
  • susemanager-doc-indexes >= 4.2-150300.12.36.3
  • susemanager-docs_en >= 4.2-150300.12.36.2
  • susemanager-docs_en-pdf >= 4.2-150300.12.36.2
  • susemanager-schema >= 4.2.25-150300.3.30.3
  • susemanager-sls >= 4.2.28-150300.3.36.2
  • susemanager-tools >= 4.2.38-150300.3.44.3
Image SLES15-SP4-Manager-Server-4-3-BYOS
Image SLES15-SP4-Manager-Server-4-3-BYOS-Azure
Image SLES15-SP4-Manager-Server-4-3-BYOS-EC2
Image SLES15-SP4-Manager-Server-4-3-BYOS-GCE
  • spacewalk-java >= 4.3.39-150400.3.11.1
  • spacewalk-java-config >= 4.3.39-150400.3.11.1
  • spacewalk-java-lib >= 4.3.39-150400.3.11.1
  • spacewalk-java-postgresql >= 4.3.39-150400.3.11.1
  • spacewalk-taskomatic >= 4.3.39-150400.3.11.1
SUSE Manager Proxy 4.2
  • release-notes-susemanager-proxy >= 4.2.10-150300.3.46.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.2-2022-3879
SUSE Manager Retail Branch Server 4.2
  • release-notes-susemanager-proxy >= 4.2.10-150300.3.46.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.2-2022-3879
SUSE Manager Server 4.2
  • release-notes-susemanager >= 4.2.10-150300.3.57.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.2-2022-3879
SUSE Manager Server Module 4.2
  • hub-xmlrpc-api >= 0.7-150300.3.9.2
  • inter-server-sync >= 0.2.4-150300.8.25.2
  • locale-formula >= 0.3-150300.3.3.2
  • py27-compat-salt >= 3000.3-150300.7.7.26.2
  • python3-spacewalk-client-tools >= 4.2.21-150300.4.27.3
  • python3-urlgrabber >= 3.10.2.1py2_3-150300.3.3.2
  • spacecmd >= 4.2.20-150300.4.30.2
  • spacewalk-backend >= 4.2.25-150300.4.32.4
  • spacewalk-backend-app >= 4.2.25-150300.4.32.4
  • spacewalk-backend-applet >= 4.2.25-150300.4.32.4
  • spacewalk-backend-config-files >= 4.2.25-150300.4.32.4
  • spacewalk-backend-config-files-common >= 4.2.25-150300.4.32.4
  • spacewalk-backend-config-files-tool >= 4.2.25-150300.4.32.4
  • spacewalk-backend-iss >= 4.2.25-150300.4.32.4
  • spacewalk-backend-iss-export >= 4.2.25-150300.4.32.4
  • spacewalk-backend-package-push-server >= 4.2.25-150300.4.32.4
  • spacewalk-backend-server >= 4.2.25-150300.4.32.4
  • spacewalk-backend-sql >= 4.2.25-150300.4.32.4
  • spacewalk-backend-sql-postgresql >= 4.2.25-150300.4.32.4
  • spacewalk-backend-tools >= 4.2.25-150300.4.32.4
  • spacewalk-backend-xml-export-libs >= 4.2.25-150300.4.32.4
  • spacewalk-backend-xmlrpc >= 4.2.25-150300.4.32.4
  • spacewalk-base >= 4.2.30-150300.3.30.3
  • spacewalk-base-minimal >= 4.2.30-150300.3.30.3
  • spacewalk-base-minimal-config >= 4.2.30-150300.3.30.3
  • spacewalk-client-tools >= 4.2.21-150300.4.27.3
  • spacewalk-html >= 4.2.30-150300.3.30.3
  • spacewalk-java >= 4.2.43-150300.3.48.2
  • spacewalk-java-config >= 4.2.43-150300.3.48.2
  • spacewalk-java-lib >= 4.2.43-150300.3.48.2
  • spacewalk-java-postgresql >= 4.2.43-150300.3.48.2
  • spacewalk-taskomatic >= 4.2.43-150300.3.48.2
  • spacewalk-utils >= 4.2.18-150300.3.21.2
  • spacewalk-utils-extras >= 4.2.18-150300.3.21.2
  • susemanager >= 4.2.38-150300.3.44.3
  • susemanager-doc-indexes >= 4.2-150300.12.36.3
  • susemanager-docs_en >= 4.2-150300.12.36.2
  • susemanager-docs_en-pdf >= 4.2-150300.12.36.2
  • susemanager-schema >= 4.2.25-150300.3.30.3
  • susemanager-sls >= 4.2.28-150300.3.36.2
  • susemanager-tools >= 4.2.38-150300.3.44.3
  • uyuni-config-modules >= 4.2.28-150300.3.36.2
Patchnames:
SUSE-SLE-Module-SUSE-Manager-Server-4.2-2022-3878
SUSE Manager Server Module 4.3
  • spacewalk-java >= 4.3.39-150400.3.11.1
  • spacewalk-java-config >= 4.3.39-150400.3.11.1
  • spacewalk-java-lib >= 4.3.39-150400.3.11.1
  • spacewalk-java-postgresql >= 4.3.39-150400.3.11.1
  • spacewalk-taskomatic >= 4.3.39-150400.3.11.1
Patchnames:
SUSE-SLE-Module-SUSE-Manager-Server-4.3-2022-3880


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Manager Proxy 4.2 release-notes-susemanager-proxy Released
SUSE Manager Retail Branch Server 4.2 release-notes-susemanager-proxy Released
SUSE Manager Server 4.2 release-notes-susemanager Released
SUSE Manager Server Module 4.2 hub-xmlrpc-api Released
SUSE Manager Server Module 4.2 inter-server-sync Released
SUSE Manager Server Module 4.2 locale-formula Released
SUSE Manager Server Module 4.2 py27-compat-salt Released
SUSE Manager Server Module 4.2 python-urlgrabber Released
SUSE Manager Server Module 4.2 spacecmd Released
SUSE Manager Server Module 4.2 spacewalk-backend Released
SUSE Manager Server Module 4.2 spacewalk-client-tools Released
SUSE Manager Server Module 4.2 spacewalk-java Released
SUSE Manager Server Module 4.2 spacewalk-utils Released
SUSE Manager Server Module 4.2 spacewalk-web Released
SUSE Manager Server Module 4.2 susemanager Released
SUSE Manager Server Module 4.2 susemanager-doc-indexes Released
SUSE Manager Server Module 4.2 susemanager-docs_en Released
SUSE Manager Server Module 4.2 susemanager-schema Released
SUSE Manager Server Module 4.2 susemanager-sls Released
SUSE Manager Server Module 4.3 spacewalk-java Released
Products past their end of life and not receiving proactive updates anymore.
SUSE Manager Server Module 4.1 spacewalk-java Not affected
openSUSE Leap 15.3 release-notes-susemanager Released


SUSE Timeline for this CVE

CVE page created: Wed Oct 26 13:00:20 2022
CVE page last modified: Wed Jan 25 10:37:22 2023