Upstream information

CVE-2022-0699 at MITRE

Description

A double-free condition exists in contrib/shpsort.c of shapelib 1.5.0 and older releases. This issue may allow an attacker to cause a denial of service or have other unspecified impact via control over malloc.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1196236 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 15 SP3
  • libshp-devel >= 1.5.0-bp153.2.3.1
  • libshp2 >= 1.5.0-bp153.2.3.1
  • shapelib >= 1.5.0-bp153.2.3.1
Patchnames:
openSUSE-2022-68
openSUSE Leap 15.3
  • libshp-devel >= 1.5.0-bp153.2.3.1
  • libshp2 >= 1.5.0-bp153.2.3.1
  • shapelib >= 1.5.0-bp153.2.3.1
Patchnames:
openSUSE-2022-68
openSUSE Leap 15.4
  • libshp2 >= 1.5.0-bp154.2.50
Patchnames:
openSUSE Leap 15.4 GA libshp2-1.5.0-bp154.2.50
openSUSE Tumbleweed
  • libshp-devel >= 1.5.0-2.1
  • libshp2 >= 1.5.0-2.1
  • shapelib >= 1.5.0-2.1
Patchnames:
openSUSE Tumbleweed GA libshp-devel-1.5.0-2.1


SUSE Timeline for this CVE

CVE page created: Mon Feb 21 11:00:16 2022
CVE page last modified: Wed Oct 26 23:33:42 2022