Upstream information

CVE-2020-22027 at MITRE

Description

A heap-based Buffer Overflow vulnerability exits in FFmpeg 4.2 in deflate16 at libavfilter/vf_neighbor.c, which might lead to memory corruption and other potential consequences.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 5.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Attack Vector Network Local
Attack Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1186607 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 ffmpeg Affected
SUSE Enterprise Storage 7.1 ffmpeg Affected
SUSE Linux Enterprise Desktop 15 SP4 ffmpeg Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 ffmpeg Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 ffmpeg Affected
SUSE Linux Enterprise Module for Package Hub 15 SP4 ffmpeg Affected
SUSE Linux Enterprise Real Time 15 SP3 ffmpeg Affected
SUSE Linux Enterprise Server 15 SP4 ffmpeg Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 ffmpeg Affected
SUSE Linux Enterprise Workstation Extension 15 SP4 ffmpeg Affected
SUSE Manager Proxy 4.2 ffmpeg Affected
SUSE Manager Proxy 4.3 ffmpeg Affected
SUSE Manager Retail Branch Server 4.2 ffmpeg Affected
SUSE Manager Retail Branch Server 4.3 ffmpeg Affected
SUSE Manager Server 4.2 ffmpeg Affected
SUSE Manager Server 4.3 ffmpeg Affected
SUSE Package Hub 15 SP4 ffmpeg Affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 ffmpeg Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ffmpeg Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS ffmpeg Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS ffmpeg Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ffmpeg Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS ffmpeg Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS ffmpeg Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 ffmpeg Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS ffmpeg Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS ffmpeg Affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS ffmpeg Affected
SUSE Linux Enterprise High Performance Computing 15-LTSS ffmpeg Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 ffmpeg Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 ffmpeg Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 ffmpeg Affected
SUSE Linux Enterprise Server 15 SP1 ffmpeg Affected
SUSE Linux Enterprise Server 15 SP1-LTSS ffmpeg Affected
SUSE Linux Enterprise Server 15 SP2 ffmpeg Affected
SUSE Linux Enterprise Server 15 SP2-LTSS ffmpeg Affected
SUSE Linux Enterprise Server 15 SP3 ffmpeg Affected
SUSE Linux Enterprise Server 15 SP3-LTSS ffmpeg Affected
SUSE Linux Enterprise Server 15-ESPOS ffmpeg Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 ffmpeg Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 ffmpeg Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP3 ffmpeg Affected
SUSE Linux Enterprise Server for SAP Applications 15 ffmpeg Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 ffmpeg Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 ffmpeg Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 ffmpeg Affected
Products past their end of life and not receiving proactive updates anymore.
SUSE CaaS Platform 4.0 ffmpeg Affected
SUSE CaaS Platform 4.5 ffmpeg Affected
SUSE Enterprise Storage 6 ffmpeg Affected
SUSE Linux Enterprise Desktop 15 ffmpeg Affected
SUSE Linux Enterprise Desktop 15 SP1 ffmpeg Affected
SUSE Linux Enterprise Desktop 15 SP2 ffmpeg Affected
SUSE Linux Enterprise Desktop 15 SP3 ffmpeg Affected
SUSE Linux Enterprise Module for Desktop Applications 15 ffmpeg Affected
SUSE Linux Enterprise Module for Package Hub 15 ffmpeg Affected
SUSE Linux Enterprise Module for Package Hub 15 SP1 ffmpeg Affected
SUSE Linux Enterprise Module for Package Hub 15 SP2 ffmpeg Affected
SUSE Linux Enterprise Module for Package Hub 15 SP3 ffmpeg Affected
SUSE Linux Enterprise Real Time 15 SP2 ffmpeg Affected
SUSE Linux Enterprise Server 15 ffmpeg Affected
SUSE Linux Enterprise Server 15 SP1-BCL ffmpeg Affected
SUSE Linux Enterprise Server 15 SP2-BCL ffmpeg Affected
SUSE Linux Enterprise Server 15 SP3-BCL ffmpeg Affected
SUSE Linux Enterprise Server 15-LTSS ffmpeg Affected
SUSE Linux Enterprise Workstation Extension 15 ffmpeg Affected
SUSE Linux Enterprise Workstation Extension 15 SP1 ffmpeg Affected
SUSE Linux Enterprise Workstation Extension 15 SP2 ffmpeg Affected
SUSE Linux Enterprise Workstation Extension 15 SP3 ffmpeg Affected
SUSE Manager Proxy 4.0 ffmpeg Unsupported
SUSE Manager Proxy 4.1 ffmpeg Affected
SUSE Manager Retail Branch Server 4.0 ffmpeg Unsupported
SUSE Manager Retail Branch Server 4.1 ffmpeg Affected
SUSE Manager Server 4.0 ffmpeg Unsupported
SUSE Manager Server 4.1 ffmpeg Affected
SUSE Package Hub 15 ffmpeg Unsupported
SUSE Package Hub 15 SP1 ffmpeg Unsupported
SUSE Package Hub 15 SP3 ffmpeg Affected


SUSE Timeline for this CVE

CVE page created: Fri May 28 01:47:50 2021
CVE page last modified: Fri Jan 20 15:33:04 2023