Upstream information

CVE-2019-9193 at MITRE

Description

** DISPUTED ** In PostgreSQL 9.3 through 11.2, the "COPY TO/FROM PROGRAM" function allows superusers and users in the 'pg_execute_server_program' group to execute arbitrary code in the context of the database's operating system user. This functionality is enabled by default and can be abused to run arbitrary operating system commands on Windows, Linux, and macOS. NOTE: Third parties claim/state this is not an issue because PostgreSQL functionality for ‘COPY TO/FROM PROGRAM’ is acting as intended. References state that in PostgreSQL, a superuser can execute commands as the server user without using the ‘COPY FROM PROGRAM’.

SUSE information

Overall state of this security issue: Ignore

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9
Vector AV:N/AC:L/Au:S/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.2 8.8
Vector AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required High Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
SUSE Bugzilla entry: 1131315 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 postgresql10 Ignore
SUSE Linux Enterprise Desktop 12 SP3 postgresql96 Ignore
SUSE Linux Enterprise Desktop 12 SP4 postgresql10 Ignore
SUSE Linux Enterprise High Performance Computing 12 postgresql10 Ignore
SUSE Linux Enterprise Module for Basesystem 15 GA postgresql10 Ignore
SUSE Linux Enterprise Module for Server Applications 15 GA postgresql10 Ignore
SUSE Linux Enterprise Server 11 SP3 LTSS postgresql94 Not affected
SUSE Linux Enterprise Server 11 SP4 postgresql94 Not affected
SUSE Linux Enterprise Server 12 GA LTSS postgresql94 Not affected
SUSE Linux Enterprise Server 12 GA LTSS postgresql96 Ignore
SUSE Linux Enterprise Server 12 SP1 LTSS postgresql94 Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS postgresql96 Ignore
SUSE Linux Enterprise Server 12 SP2 LTSS postgresql94 Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS postgresql96 Ignore
SUSE Linux Enterprise Server 12 SP3 postgresql10 Ignore
SUSE Linux Enterprise Server 12 SP3 postgresql96 Ignore
SUSE Linux Enterprise Server 12 SP4 postgresql10 Ignore
SUSE Linux Enterprise Server for SAP Applications 11 SP3 postgresql94 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 GA postgresql94 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 postgresql94 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 postgresql96 Ignore
SUSE Linux Enterprise Server for SAP Applications 12 SP4 postgresql10 Ignore