Upstream information

CVE-2019-17362 at MITRE

Description

In LibTomCrypt through 1.18.2, the der_decode_utf8_string function (in der_decode_utf8_string.c) does not properly detect certain invalid UTF-8 sequences. This allows context-dependent attackers to cause a denial of service (out-of-bounds read and crash) or read information from other memory locations via carefully crafted DER-encoded data.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.4
Vector AV:N/AC:L/Au:N/C:P/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.1 5.1
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact None None
Availability Impact High Low
CVSSv3 Version 3.1 3
SUSE Bugzilla entry: 1153433 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP4
  • libtomcrypt0 >= 1.17-3.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-3095
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • libtomcrypt-devel >= 1.17-3.3.1
  • libtomcrypt-examples >= 1.17-3.3.1
  • libtomcrypt0 >= 1.17-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2808
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • libtomcrypt-devel >= 1.17-3.3.1
  • libtomcrypt-examples >= 1.17-3.3.1
  • libtomcrypt0 >= 1.17-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-2808
SUSE Linux Enterprise Workstation Extension 12 SP4
  • libtomcrypt0 >= 1.17-3.3.1
Patchnames:
SUSE-SLE-WE-12-SP4-2019-3095
SUSE Linux Enterprise Workstation Extension 12 SP5
  • libtomcrypt0 >= 1.17-3.3.1
Patchnames:
SUSE-SLE-WE-12-SP5-2019-3095
openSUSE Leap 15.0
  • libtomcrypt-devel >= 1.17-lp150.2.3.1
  • libtomcrypt-examples >= 1.17-lp150.2.3.1
  • libtomcrypt0 >= 1.17-lp150.2.3.1
Patchnames:
openSUSE-2019-2454
openSUSE Leap 15.1
  • libtomcrypt-devel >= 1.17-lp151.3.3.1
  • libtomcrypt-examples >= 1.17-lp151.3.3.1
  • libtomcrypt0 >= 1.17-lp151.3.3.1
Patchnames:
openSUSE-2019-2514


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP4 libtomcrypt Released
SUSE Linux Enterprise Workstation Extension 12 SP4 libtomcrypt Released
SUSE Linux Enterprise Workstation Extension 12 SP5 libtomcrypt Released