Upstream information

CVE-2019-13314 at MITRE

Description

virt-bootstrap 1.1.0 allows local users to discover a root password by listing a process, because this password may be present in the --root-password option to virt_bootstrap.py.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:P/I:N/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 2.8
Vector CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low Low
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High None
Availability Impact High None
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1140750 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • python2-virt-bootstrap >= 1.0.0-5.3.124
  • virt-bootstrap >= 1.0.0-5.3.124
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-3045
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • python2-virt-bootstrap >= 1.0.0-5.3.124
  • virt-bootstrap >= 1.0.0-5.3.124
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2020-3045
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • python3-virt-bootstrap >= 1.0.0-5.3.124
  • virt-bootstrap >= 1.0.0-5.3.124
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP1-2020-3045
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • python3-virt-bootstrap >= 1.0.0-5.3.124
  • virt-bootstrap >= 1.0.0-5.3.124
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP2-2020-3045
openSUSE Leap 15.1
  • python2-virt-bootstrap >= 1.0.0-lp151.4.3.1
  • python3-virt-bootstrap >= 1.0.0-lp151.4.3.1
  • virt-bootstrap >= 1.0.0-lp151.4.3.1
Patchnames:
openSUSE-2020-1856
openSUSE Leap 15.2
  • python2-virt-bootstrap >= 1.0.0-lp152.5.3.1
  • python3-virt-bootstrap >= 1.0.0-lp152.5.3.1
  • virt-bootstrap >= 1.0.0-lp152.5.3.1
Patchnames:
openSUSE-2020-1787


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise 15 Module for Server Applications virt-bootstrap In progress
SUSE Linux Enterprise 15-SP1 Module for Server Applications virt-bootstrap Released
SUSE Linux Enterprise 15-SP2 Module for Server Applications virt-bootstrap Released