Upstream information

CVE-2018-5801 at MITRE

Description

An error within the "LibRaw::unpack()" function (src/libraw_cxx.cpp) in LibRaw versions prior to 0.18.7 can be exploited to trigger a NULL pointer dereference.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 3.3
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High Low
SUSE Bugzilla entry: 1084690 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • libraw >= 0.15.4-21.1
  • libraw9 >= 0.15.4-21.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-2402
SUSE Linux Enterprise Desktop 12 SP4
  • libraw9 >= 0.15.4-21.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA libraw9
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libraw >= 0.15.4-21.1
  • libraw-devel >= 0.15.4-21.1
  • libraw-devel-static >= 0.15.4-21.1
  • libraw9 >= 0.15.4-21.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-2402
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libraw-devel >= 0.15.4-21.1
  • libraw-devel-static >= 0.15.4-21.1
  • libraw9 >= 0.15.4-21.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libraw-devel
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libraw >= 0.15.4-21.1
  • libraw9 >= 0.15.4-21.1
Patchnames:
SUSE-SLE-WE-12-SP3-2018-2402
SUSE Linux Enterprise Workstation Extension 12 SP4
  • libraw9 >= 0.15.4-21.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP4 GA libraw9
openSUSE Leap 42.3
  • libraw >= 0.17.1-17.1
  • libraw-debugsource >= 0.17.1-17.1
  • libraw-devel >= 0.17.1-17.1
  • libraw-devel-static >= 0.17.1-17.1
  • libraw-tools >= 0.17.1-17.1
  • libraw-tools-debuginfo >= 0.17.1-17.1
  • libraw15 >= 0.17.1-17.1
  • libraw15-debuginfo >= 0.17.1-17.1
Patchnames:
openSUSE-2018-281


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 libraw Affected
SUSE Linux Enterprise Desktop 12 SP3 libraw Released
SUSE Linux Enterprise SDK 12 SP2 libraw In progress
SUSE Linux Enterprise SDK 12 SP3 libraw Released
SUSE Linux Enterprise Workstation Extension 12 SP2 libraw In progress
SUSE Linux Enterprise Workstation Extension 12 SP3 libraw Released