Upstream information

CVE-2018-20860 at MITRE

Description

libopenmpt before 0.3.13 allows a crash with malformed MED files.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 4.3
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High Low
SUSE Bugzilla entry: 1143581 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Desktop Applications 15
  • libmodplug-devel >= 0.3.17-2.7.1
  • libmodplug1 >= 0.3.17-2.7.1
  • libopenmpt >= 0.3.17-2.7.1
  • libopenmpt-devel >= 0.3.17-2.7.1
  • libopenmpt0 >= 0.3.17-2.7.1
  • libopenmpt_modplug1 >= 0.3.17-2.7.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2019-2435
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • libmodplug-devel >= 0.3.17-2.7.1
  • libmodplug1 >= 0.3.17-2.7.1
  • libopenmpt >= 0.3.17-2.7.1
  • libopenmpt-devel >= 0.3.17-2.7.1
  • libopenmpt0 >= 0.3.17-2.7.1
  • libopenmpt_modplug1 >= 0.3.17-2.7.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP1-2019-2435
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • libopenmpt >= 0.3.17-2.7.1
  • openmpt123 >= 0.3.17-2.7.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-2435
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • libmodplug1-32bit >= 0.3.17-2.7.1
  • libopenmpt >= 0.3.17-2.7.1
  • libopenmpt0-32bit >= 0.3.17-2.7.1
  • libopenmpt_modplug1-32bit >= 0.3.17-2.7.1
  • openmpt123 >= 0.3.17-2.7.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2435
openSUSE Leap 15.0
  • libmodplug-devel >= 0.3.17-lp150.7.1
  • libmodplug1 >= 0.3.17-lp150.7.1
  • libmodplug1-32bit >= 0.3.17-lp150.7.1
  • libmodplug1-32bit-debuginfo >= 0.3.17-lp150.7.1
  • libmodplug1-debuginfo >= 0.3.17-lp150.7.1
  • libopenmpt >= 0.3.17-lp150.7.1
  • libopenmpt-debugsource >= 0.3.17-lp150.7.1
  • libopenmpt-devel >= 0.3.17-lp150.7.1
  • libopenmpt0 >= 0.3.17-lp150.7.1
  • libopenmpt0-32bit >= 0.3.17-lp150.7.1
  • libopenmpt0-32bit-debuginfo >= 0.3.17-lp150.7.1
  • libopenmpt0-debuginfo >= 0.3.17-lp150.7.1
  • libopenmpt_modplug1 >= 0.3.17-lp150.7.1
  • libopenmpt_modplug1-32bit >= 0.3.17-lp150.7.1
  • libopenmpt_modplug1-32bit-debuginfo >= 0.3.17-lp150.7.1
  • libopenmpt_modplug1-debuginfo >= 0.3.17-lp150.7.1
  • openmpt123 >= 0.3.17-lp150.7.1
  • openmpt123-debuginfo >= 0.3.17-lp150.7.1
Patchnames:
openSUSE-2019-2212
openSUSE Leap 15.1
  • libmodplug-devel >= 0.3.17-lp151.2.3.1
  • libmodplug1 >= 0.3.17-lp151.2.3.1
  • libmodplug1-32bit >= 0.3.17-lp151.2.3.1
  • libmodplug1-32bit-debuginfo >= 0.3.17-lp151.2.3.1
  • libmodplug1-debuginfo >= 0.3.17-lp151.2.3.1
  • libopenmpt >= 0.3.17-lp151.2.3.1
  • libopenmpt-debugsource >= 0.3.17-lp151.2.3.1
  • libopenmpt-devel >= 0.3.17-lp151.2.3.1
  • libopenmpt0 >= 0.3.17-lp151.2.3.1
  • libopenmpt0-32bit >= 0.3.17-lp151.2.3.1
  • libopenmpt0-32bit-debuginfo >= 0.3.17-lp151.2.3.1
  • libopenmpt0-debuginfo >= 0.3.17-lp151.2.3.1
  • libopenmpt_modplug1 >= 0.3.17-lp151.2.3.1
  • libopenmpt_modplug1-32bit >= 0.3.17-lp151.2.3.1
  • libopenmpt_modplug1-32bit-debuginfo >= 0.3.17-lp151.2.3.1
  • libopenmpt_modplug1-debuginfo >= 0.3.17-lp151.2.3.1
  • openmpt123 >= 0.3.17-lp151.2.3.1
  • openmpt123-debuginfo >= 0.3.17-lp151.2.3.1
Patchnames:
openSUSE-2019-2213


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Desktop Applications 15 GA libopenmpt Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 libopenmpt Released