Upstream information

CVE-2018-18074 at MITRE

Description

The Requests package before 2.20.0 for Python sends an HTTP Authorization header to an http URI upon receiving a same-hostname https-to-http redirect, which makes it easier for remote attackers to discover credentials by sniffing the network.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 5.9
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High None
Availability Impact High None
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1111622 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container caasp/v4/hyperkube:v1.17.4
Container caasp/v4/k8s-sidecar:0.1.75
Container caasp/v5/k8s-sidecar:beta
Image SLES15-SP1-CHOST-BYOS-Ali
Image SLES15-SP1-CHOST-BYOS-EC2
Image SLES15-SP1-CHOST-BYOS-OpenStack
Image SLES15-SP2-CHOST-BYOS-Ali
Image SLES15-SP2-CHOST-BYOS-Azure
Image SLES15-SP2-CHOST-BYOS-EC2
Image SLES15-SP2-CHOST-BYOS-OpenStack
Image caasp-k8s-sidecar-image
  • python3-requests >= 2.20.1-6.3.2
HPE Helion Openstack 8
  • python-PyYAML >= 5.1.2-26.9.4
  • python-asn1crypto >= 0.24.0-2.5.1
  • python-botocore >= 1.12.213-28.12.1
  • python-certifi >= 2018.4.16-3.6.1
  • python-chardet >= 3.0.4-5.6.1
  • python-jsonpatch >= 1.1-10.4.1
  • python-jsonpointer >= 1.0-10.3.1
  • python-packaging >= 17.1-2.5.1
  • python-urllib3 >= 1.22-3.20.1
  • python3-PyYAML >= 5.1.2-26.9.4
  • python3-asn1crypto >= 0.24.0-2.5.1
  • python3-certifi >= 2018.4.16-3.6.1
  • python3-chardet >= 3.0.4-5.6.1
  • python3-jsonpointer >= 1.0-10.3.1
  • python3-packaging >= 17.1-2.5.1
  • python3-requests >= 2.20.1-5.2
  • python3-urllib3 >= 1.22-3.20.1
Patchnames:
HPE-Helion-OpenStack-8-2020-1792
HPE-Helion-OpenStack-8-2020-555
SUSE CaaS Platform 3.0
  • python-PyYAML >= 5.1.2-26.9.4
  • python-jsonpatch >= 1.1-10.4.1
  • python-jsonpointer >= 1.0-10.3.1
Patchnames:
SUSE-CAASP-3.0-2020-555
SUSE Enterprise Storage 5
  • python-PyYAML >= 5.1.2-26.9.4
  • python-asn1crypto >= 0.24.0-2.5.1
  • python-certifi >= 2018.4.16-3.6.1
  • python-chardet >= 3.0.4-5.6.1
  • python-packaging >= 17.1-2.5.1
  • python-urllib3 >= 1.22-3.20.1
  • python3-PyYAML >= 5.1.2-26.9.4
  • python3-asn1crypto >= 0.24.0-2.5.1
  • python3-certifi >= 2018.4.16-3.6.1
  • python3-chardet >= 3.0.4-5.6.1
  • python3-packaging >= 17.1-2.5.1
  • python3-requests >= 2.20.1-5.2
  • python3-urllib3 >= 1.22-3.20.1
Patchnames:
SUSE-Storage-5-2020-1792
SUSE-Storage-5-2020-555
SUSE Linux Enterprise High Availability 12 SP1
  • python-PyYAML >= 5.1.2-26.9.4
  • python-asn1crypto >= 0.24.0-2.5.1
  • python-packaging >= 17.1-2.5.1
  • python-pyparsing >= 2.2.0-7.6.1
  • python3-asn1crypto >= 0.24.0-2.5.1
  • python3-packaging >= 17.1-2.5.1
  • python3-pyparsing >= 2.2.0-7.6.1
Patchnames:
SUSE-SLE-HA-12-SP1-2020-555
SUSE Linux Enterprise High Availability 12 SP2
  • python-PyYAML >= 5.1.2-26.9.4
Patchnames:
SUSE-SLE-HA-12-SP2-2020-555
SUSE Linux Enterprise High Availability 12 SP5
  • python-requests >= 2.20.1-8.7.7
Patchnames:
SUSE-SLE-HA-12-SP5-2020-555
SUSE Linux Enterprise Module for Advanced Systems Management 12
  • python-PyYAML >= 5.1.2-26.9.4
  • python3-PyYAML >= 5.1.2-26.9.4
Patchnames:
SUSE-SLE-Module-Adv-Systems-Management-12-2020-555
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • python-requests >= 2.20.1-6.3.2
  • python3-requests >= 2.20.1-6.3.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-1487
SUSE Linux Enterprise Module for Containers 12
  • python-PyYAML >= 5.1.2-26.9.4
Patchnames:
SUSE-SLE-Module-Containers-12-2020-555
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • python-requests-test >= 2.20.1-6.3.2
  • python2-requests-test >= 2.20.1-6.3.2
  • python3-requests-test >= 2.20.1-6.3.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-1487
SUSE Linux Enterprise Module for Public Cloud 12
  • cfn-lint >= 0.21.4-2.3.1
  • python-PyYAML >= 5.1.2-26.9.4
  • python-aws-sam-translator >= 1.11.0-2.3.1
  • python-boto3 >= 1.9.213-14.9.1
  • python-botocore >= 1.12.213-28.12.1
  • python-certifi >= 2018.4.16-3.6.1
  • python-cfn-lint >= 0.21.4-2.3.1
  • python-chardet >= 3.0.4-5.6.1
  • python-docutils >= 0.15.2-3.4.2
  • python-functools32 >= 3.2.3.2-2.6.1
  • python-jsonpatch >= 1.1-10.4.1
  • python-jsonpointer >= 1.0-10.3.1
  • python-jsonschema >= 2.6.0-5.3.1
  • python-requests >= 2.20.1-8.7.7
  • python-s3transfer >= 0.2.1-8.3.1
  • python-urllib3 >= 1.22-3.20.1
  • python3-PyYAML >= 5.1.2-26.9.4
  • python3-aws-sam-translator >= 1.11.0-2.3.1
  • python3-boto3 >= 1.9.213-14.9.1
  • python3-botocore >= 1.12.213-28.12.1
  • python3-certifi >= 2018.4.16-3.6.1
  • python3-cfn-lint >= 0.21.4-2.3.1
  • python3-chardet >= 3.0.4-5.6.1
  • python3-docutils >= 0.15.2-3.4.2
  • python3-jsonpatch >= 1.1-10.4.1
  • python3-jsonpointer >= 1.0-10.3.1
  • python3-jsonschema >= 2.6.0-5.3.1
  • python3-requests >= 2.20.1-8.7.7
  • python3-s3transfer >= 0.2.1-8.3.1
  • python3-urllib3 >= 1.22-3.20.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-12-2020-1792
SUSE-SLE-Module-Public-Cloud-12-2020-555
SUSE Linux Enterprise Module for Python2 packages 15 SP1
  • python-requests >= 2.20.1-6.3.2
  • python2-requests >= 2.20.1-6.3.2
Patchnames:
SUSE-SLE-Module-Python2-15-SP1-2019-1487
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • python-asn1crypto >= 0.24.0-2.5.1
  • python-certifi >= 2018.4.16-3.6.1
  • python-chardet >= 3.0.4-5.6.1
  • python-packaging >= 17.1-2.5.1
  • python-pyparsing >= 2.2.0-7.6.1
  • python-urllib3 >= 1.22-3.20.1
  • python3-asn1crypto >= 0.24.0-2.5.1
  • python3-certifi >= 2018.4.16-3.6.1
  • python3-chardet >= 3.0.4-5.6.1
  • python3-packaging >= 17.1-2.5.1
  • python3-pyparsing >= 2.2.0-7.6.1
  • python3-requests >= 2.20.1-5.2
  • python3-urllib3 >= 1.22-3.20.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2020-1792
SUSE-SLE-POS-12-SP2-CLIENT-2020-555
SUSE Linux Enterprise Point of Sale 12 SP2
  • python-PyYAML >= 5.1.2-26.9.4
  • python3-PyYAML >= 5.1.2-26.9.4
Patchnames:
SUSE-SLE-POS-12-SP2-2020-555
SUSE Linux Enterprise Server 12 SP1-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • python-asn1crypto >= 0.24.0-2.5.1
  • python-packaging >= 17.1-2.5.1
  • python-pyparsing >= 2.2.0-7.6.1
  • python3-asn1crypto >= 0.24.0-2.5.1
  • python3-packaging >= 17.1-2.5.1
  • python3-pyparsing >= 2.2.0-7.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2020-555
SUSE Linux Enterprise Server 12 SP2-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • python-asn1crypto >= 0.24.0-2.5.1
  • python-certifi >= 2018.4.16-3.6.1
  • python-chardet >= 3.0.4-5.6.1
  • python-packaging >= 17.1-2.5.1
  • python-pyparsing >= 2.2.0-7.6.1
  • python-urllib3 >= 1.22-3.20.1
  • python3-asn1crypto >= 0.24.0-2.5.1
  • python3-certifi >= 2018.4.16-3.6.1
  • python3-chardet >= 3.0.4-5.6.1
  • python3-packaging >= 17.1-2.5.1
  • python3-pyparsing >= 2.2.0-7.6.1
  • python3-requests >= 2.20.1-5.2
  • python3-urllib3 >= 1.22-3.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2020-1792
SUSE-SLE-SERVER-12-SP2-BCL-2020-555
SUSE Linux Enterprise Server 12 SP2-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • python-asn1crypto >= 0.24.0-2.5.1
  • python-certifi >= 2018.4.16-3.6.1
  • python-chardet >= 3.0.4-5.6.1
  • python-packaging >= 17.1-2.5.1
  • python-pyparsing >= 2.2.0-7.6.1
  • python-urllib3 >= 1.22-3.20.1
  • python3-asn1crypto >= 0.24.0-2.5.1
  • python3-certifi >= 2018.4.16-3.6.1
  • python3-chardet >= 3.0.4-5.6.1
  • python3-packaging >= 17.1-2.5.1
  • python3-pyparsing >= 2.2.0-7.6.1
  • python3-requests >= 2.20.1-5.2
  • python3-urllib3 >= 1.22-3.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2020-1792
SUSE-SLE-SERVER-12-SP2-ESPOS-2020-555
SUSE Linux Enterprise Server 12 SP2-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • python-asn1crypto >= 0.24.0-2.5.1
  • python-certifi >= 2018.4.16-3.6.1
  • python-chardet >= 3.0.4-5.6.1
  • python-packaging >= 17.1-2.5.1
  • python-pyparsing >= 2.2.0-7.6.1
  • python-urllib3 >= 1.22-3.20.1
  • python3-asn1crypto >= 0.24.0-2.5.1
  • python3-certifi >= 2018.4.16-3.6.1
  • python3-chardet >= 3.0.4-5.6.1
  • python3-packaging >= 17.1-2.5.1
  • python3-pyparsing >= 2.2.0-7.6.1
  • python3-requests >= 2.20.1-5.2
  • python3-urllib3 >= 1.22-3.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2020-1792
SUSE-SLE-SERVER-12-SP2-2020-555
SUSE Linux Enterprise Server 12 SP3-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • python-PyYAML >= 5.1.2-26.9.4
  • python-asn1crypto >= 0.24.0-2.5.1
  • python-certifi >= 2018.4.16-3.6.1
  • python-chardet >= 3.0.4-5.6.1
  • python-packaging >= 17.1-2.5.1
  • python-urllib3 >= 1.22-3.20.1
  • python3-PyYAML >= 5.1.2-26.9.4
  • python3-asn1crypto >= 0.24.0-2.5.1
  • python3-certifi >= 2018.4.16-3.6.1
  • python3-chardet >= 3.0.4-5.6.1
  • python3-packaging >= 17.1-2.5.1
  • python3-requests >= 2.20.1-5.2
  • python3-urllib3 >= 1.22-3.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2020-1792
SUSE-SLE-SERVER-12-SP3-BCL-2020-555
SUSE Linux Enterprise Server 12 SP3-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • python-PyYAML >= 5.1.2-26.9.4
  • python-asn1crypto >= 0.24.0-2.5.1
  • python-certifi >= 2018.4.16-3.6.1
  • python-chardet >= 3.0.4-5.6.1
  • python-packaging >= 17.1-2.5.1
  • python-urllib3 >= 1.22-3.20.1
  • python3-PyYAML >= 5.1.2-26.9.4
  • python3-asn1crypto >= 0.24.0-2.5.1
  • python3-certifi >= 2018.4.16-3.6.1
  • python3-chardet >= 3.0.4-5.6.1
  • python3-packaging >= 17.1-2.5.1
  • python3-requests >= 2.20.1-5.2
  • python3-urllib3 >= 1.22-3.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2020-1792
SUSE-SLE-SERVER-12-SP3-ESPOS-2020-555
SUSE Linux Enterprise Server 12 SP3-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • python-PyYAML >= 5.1.2-26.9.4
  • python-asn1crypto >= 0.24.0-2.5.1
  • python-certifi >= 2018.4.16-3.6.1
  • python-chardet >= 3.0.4-5.6.1
  • python-packaging >= 17.1-2.5.1
  • python-urllib3 >= 1.22-3.20.1
  • python3-PyYAML >= 5.1.2-26.9.4
  • python3-asn1crypto >= 0.24.0-2.5.1
  • python3-certifi >= 2018.4.16-3.6.1
  • python3-chardet >= 3.0.4-5.6.1
  • python3-packaging >= 17.1-2.5.1
  • python3-requests >= 2.20.1-5.2
  • python3-urllib3 >= 1.22-3.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2020-1792
SUSE-SLE-SERVER-12-SP3-2020-555
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • python-PyYAML >= 5.1.2-26.9.4
  • python-asn1crypto >= 0.24.0-2.5.1
  • python-certifi >= 2018.4.16-3.6.1
  • python-chardet >= 3.0.4-5.6.1
  • python-packaging >= 17.1-2.5.1
  • python-urllib3 >= 1.22-3.20.1
  • python3-asn1crypto >= 0.24.0-2.5.1
  • python3-certifi >= 2018.4.16-3.6.1
  • python3-chardet >= 3.0.4-5.6.1
  • python3-packaging >= 17.1-2.5.1
  • python3-requests >= 2.20.1-5.2
  • python3-urllib3 >= 1.22-3.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2020-1792
SUSE-SLE-SERVER-12-SP4-2020-555
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • python-PyYAML >= 5.1.2-26.9.4
  • python-asn1crypto >= 0.24.0-2.5.1
  • python-certifi >= 2018.4.16-3.6.1
  • python-chardet >= 3.0.4-5.6.1
  • python-packaging >= 17.1-2.5.1
  • python-requests >= 2.20.1-8.7.7
  • python-urllib3 >= 1.22-3.20.1
  • python3-asn1crypto >= 0.24.0-2.5.1
  • python3-certifi >= 2018.4.16-3.6.1
  • python3-chardet >= 3.0.4-5.6.1
  • python3-packaging >= 17.1-2.5.1
  • python3-requests >= 2.20.1-5.2
  • python3-urllib3 >= 1.22-3.20.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2020-1792
SUSE-SLE-SERVER-12-SP5-2020-555
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • python-asn1crypto >= 0.24.0-2.5.1
  • python-packaging >= 17.1-2.5.1
  • python-pyparsing >= 2.2.0-7.6.1
  • python3-asn1crypto >= 0.24.0-2.5.1
  • python3-packaging >= 17.1-2.5.1
  • python3-pyparsing >= 2.2.0-7.6.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2020-555
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • python-asn1crypto >= 0.24.0-2.5.1
  • python-certifi >= 2018.4.16-3.6.1
  • python-chardet >= 3.0.4-5.6.1
  • python-packaging >= 17.1-2.5.1
  • python-pyparsing >= 2.2.0-7.6.1
  • python-urllib3 >= 1.22-3.20.1
  • python3-asn1crypto >= 0.24.0-2.5.1
  • python3-certifi >= 2018.4.16-3.6.1
  • python3-chardet >= 3.0.4-5.6.1
  • python3-packaging >= 17.1-2.5.1
  • python3-pyparsing >= 2.2.0-7.6.1
  • python3-requests >= 2.20.1-5.2
  • python3-urllib3 >= 1.22-3.20.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2020-1792
SUSE-SLE-SAP-12-SP2-2020-555
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • python-PyYAML >= 5.1.2-26.9.4
  • python-asn1crypto >= 0.24.0-2.5.1
  • python-certifi >= 2018.4.16-3.6.1
  • python-chardet >= 3.0.4-5.6.1
  • python-packaging >= 17.1-2.5.1
  • python-urllib3 >= 1.22-3.20.1
  • python3-PyYAML >= 5.1.2-26.9.4
  • python3-asn1crypto >= 0.24.0-2.5.1
  • python3-certifi >= 2018.4.16-3.6.1
  • python3-chardet >= 3.0.4-5.6.1
  • python3-packaging >= 17.1-2.5.1
  • python3-requests >= 2.20.1-5.2
  • python3-urllib3 >= 1.22-3.20.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2020-1792
SUSE-SLE-SAP-12-SP3-2020-555
SUSE Linux Enterprise Software Development Kit 12 SP5
  • python-certifi >= 2018.4.16-3.6.1
  • python-chardet >= 3.0.4-5.6.1
  • python-urllib3 >= 1.22-3.20.1
  • python3-certifi >= 2018.4.16-3.6.1
  • python3-chardet >= 3.0.4-5.6.1
  • python3-requests >= 2.20.1-5.2
  • python3-urllib3 >= 1.22-3.20.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2020-1792
SUSE Linux Enterprise Workstation Extension 12 SP5
  • python-certifi >= 2018.4.16-3.6.1
  • python-chardet >= 3.0.4-5.6.1
  • python-urllib3 >= 1.22-3.20.1
  • python3-certifi >= 2018.4.16-3.6.1
  • python3-chardet >= 3.0.4-5.6.1
  • python3-requests >= 2.20.1-5.2
  • python3-urllib3 >= 1.22-3.20.1
Patchnames:
SUSE-SLE-WE-12-SP5-2020-1792
SUSE Manager Proxy 3.2
  • python-PyYAML >= 5.1.2-26.9.4
  • python-certifi >= 2018.4.16-3.6.1
  • python-chardet >= 3.0.4-5.6.1
  • python-urllib3 >= 1.22-3.20.1
  • python3-certifi >= 2018.4.16-3.6.1
  • python3-chardet >= 3.0.4-5.6.1
  • python3-requests >= 2.20.1-5.2
  • python3-urllib3 >= 1.22-3.20.1
Patchnames:
SUSE-SUSE-Manager-Proxy-3.2-2020-1792
SUSE-SUSE-Manager-Proxy-3.2-2020-555
SUSE Manager Server 3.2
  • python-PyYAML >= 5.1.2-26.9.4
  • python-certifi >= 2018.4.16-3.6.1
  • python-chardet >= 3.0.4-5.6.1
  • python-urllib3 >= 1.22-3.20.1
  • python3-certifi >= 2018.4.16-3.6.1
  • python3-chardet >= 3.0.4-5.6.1
  • python3-requests >= 2.20.1-5.2
  • python3-urllib3 >= 1.22-3.20.1
Patchnames:
SUSE-SUSE-Manager-Server-3.2-2020-1792
SUSE-SUSE-Manager-Server-3.2-2020-555
SUSE Manager Tools 12
  • python-PyYAML >= 5.1.2-26.9.4
  • python3-PyYAML >= 5.1.2-26.9.4
Patchnames:
SUSE-SLE-Manager-Tools-12-2020-555
SUSE OpenStack Cloud 7
  • python-PyYAML >= 5.1.2-26.9.4
  • python-asn1crypto >= 0.24.0-2.5.1
  • python-certifi >= 2018.4.16-3.6.1
  • python-chardet >= 3.0.4-5.6.1
  • python-jsonpatch >= 1.1-10.4.1
  • python-jsonpointer >= 1.0-10.3.1
  • python-packaging >= 17.1-2.5.1
  • python-pyparsing >= 2.2.0-7.6.1
  • python-requests >= 2.11.1-6.31.1
  • python-urllib3 >= 1.22-3.20.1
  • python3-asn1crypto >= 0.24.0-2.5.1
  • python3-certifi >= 2018.4.16-3.6.1
  • python3-chardet >= 3.0.4-5.6.1
  • python3-jsonpointer >= 1.0-10.3.1
  • python3-packaging >= 17.1-2.5.1
  • python3-pyparsing >= 2.2.0-7.6.1
  • python3-requests >= 2.20.1-5.2
  • python3-urllib3 >= 1.22-3.20.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-2027
SUSE-OpenStack-Cloud-7-2020-1792
SUSE-OpenStack-Cloud-7-2020-555
SUSE OpenStack Cloud 8
  • python-PyYAML >= 5.1.2-26.9.4
  • python-asn1crypto >= 0.24.0-2.5.1
  • python-botocore >= 1.12.213-28.12.1
  • python-certifi >= 2018.4.16-3.6.1
  • python-chardet >= 3.0.4-5.6.1
  • python-jsonpatch >= 1.1-10.4.1
  • python-jsonpointer >= 1.0-10.3.1
  • python-packaging >= 17.1-2.5.1
  • python-urllib3 >= 1.22-3.20.1
  • python3-PyYAML >= 5.1.2-26.9.4
  • python3-asn1crypto >= 0.24.0-2.5.1
  • python3-certifi >= 2018.4.16-3.6.1
  • python3-chardet >= 3.0.4-5.6.1
  • python3-jsonpointer >= 1.0-10.3.1
  • python3-packaging >= 17.1-2.5.1
  • python3-requests >= 2.20.1-5.2
  • python3-urllib3 >= 1.22-3.20.1
Patchnames:
SUSE-OpenStack-Cloud-8-2020-1792
SUSE-OpenStack-Cloud-8-2020-555
SUSE OpenStack Cloud 9
  • python-requests >= 2.20.1-4.3.1
Patchnames:
SUSE-OpenStack-Cloud-9-2019-2047
SUSE OpenStack Cloud Crowbar 8
  • python-PyYAML >= 5.1.2-26.9.4
  • python-asn1crypto >= 0.24.0-2.5.1
  • python-botocore >= 1.12.213-28.12.1
  • python-certifi >= 2018.4.16-3.6.1
  • python-chardet >= 3.0.4-5.6.1
  • python-jsonpatch >= 1.1-10.4.1
  • python-jsonpointer >= 1.0-10.3.1
  • python-packaging >= 17.1-2.5.1
  • python-urllib3 >= 1.22-3.20.1
  • python3-PyYAML >= 5.1.2-26.9.4
  • python3-asn1crypto >= 0.24.0-2.5.1
  • python3-certifi >= 2018.4.16-3.6.1
  • python3-chardet >= 3.0.4-5.6.1
  • python3-jsonpointer >= 1.0-10.3.1
  • python3-packaging >= 17.1-2.5.1
  • python3-requests >= 2.20.1-5.2
  • python3-urllib3 >= 1.22-3.20.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2020-1792
SUSE-OpenStack-Cloud-Crowbar-8-2020-555
SUSE OpenStack Cloud Crowbar 9
  • python-requests >= 2.20.1-4.3.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2019-2047
openSUSE Leap 15.1
  • python-requests >= 2.20.1-lp151.2.3.1
  • python-requests-test >= 2.20.1-lp151.2.3.1
  • python2-requests >= 2.20.1-lp151.2.3.1
  • python2-requests-test >= 2.20.1-lp151.2.3.1
  • python3-requests >= 2.20.1-lp151.2.3.1
  • python3-requests-test >= 2.20.1-lp151.2.3.1
Patchnames:
openSUSE-2019-1754


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 python-requests Affected
CaaS Platform 2.0 python-requests Affected
CaaS Platform 3.0 python-requests Released
HPE Helion OpenStack 8 python-requests Affected
OpenStack Cloud Magnum Orchestration 7.0 python-requests In progress
SUSE Business Critical Linux 12 SP2 python-requests Released
SUSE Business Critical Linux 12 SP3 python-requests Released
SUSE Linux Enterprise Client Tools for SUSE Manager 12 GA python-requests Released
SUSE Linux Enterprise Desktop 12 SP3 python-requests Affected
SUSE Linux Enterprise High Availability 12 GA python-requests Affected
SUSE Linux Enterprise High Availability 12 SP2 python-requests Released
SUSE Linux Enterprise High Availability 12 SP3 python-requests Affected
SUSE Linux Enterprise High Availability 12 SP5 python-requests Released
SUSE Linux Enterprise High Performance Computing 12 python-requests Released
SUSE Linux Enterprise Module for Advanced Systems Management 12 python-requests Released
SUSE Linux Enterprise Module for Basesystem 15 GA python-requests Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 python-requests Released
SUSE Linux Enterprise Module for Public Cloud 12 python-requests Released
SUSE Linux Enterprise Module for Python2 15 SP1 python-requests Released
SUSE Linux Enterprise Server 11 SP3 LTSS python-requests Affected
SUSE Linux Enterprise Server 11 SP4 python-requests Affected
SUSE Linux Enterprise Server 12 GA LTSS python-requests Affected
SUSE Linux Enterprise Server 12 SP1 LTSS python-requests Released
SUSE Linux Enterprise Server 12 SP2 LTSS python-requests Released
SUSE Linux Enterprise Server 12 SP3 python-requests Affected
SUSE Linux Enterprise Server 12 SP3 LTSS python-requests Released
SUSE Linux Enterprise Server 12 SP4 python-requests Released
SUSE Linux Enterprise Server 12 SP5 python-requests Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 python-requests Affected
SUSE Linux Enterprise Server for SAP Applications 12 GA python-requests Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 python-requests Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 python-requests Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 python-requests Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 python-requests Released
SUSE Openstack Cloud 7 python-requests Released
SUSE Openstack Cloud 8 python-requests Affected
SUSE Openstack Cloud 9 python-requests Released