Upstream information

CVE-2018-16429 at MITRE

Description

GNOME GLib 2.56.1 has an out-of-bounds read vulnerability in g_markup_parse_context_parse() in gmarkup.c, related to utf8_str().

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 4
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None Low
Integrity Impact None None
Availability Impact High None
SUSE Bugzilla entry: 1107116 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • glib2 >= 2.54.3-4.7.1
  • glib2-devel >= 2.54.3-4.7.1
  • glib2-lang >= 2.54.3-4.7.1
  • glib2-tools >= 2.54.3-4.7.1
  • libgio-2_0-0 >= 2.54.3-4.7.1
  • libgio-2_0-0-32bit >= 2.54.3-4.7.1
  • libglib-2_0-0 >= 2.54.3-4.7.1
  • libglib-2_0-0-32bit >= 2.54.3-4.7.1
  • libgmodule-2_0-0 >= 2.54.3-4.7.1
  • libgmodule-2_0-0-32bit >= 2.54.3-4.7.1
  • libgobject-2_0-0 >= 2.54.3-4.7.1
  • libgobject-2_0-0-32bit >= 2.54.3-4.7.1
  • libgthread-2_0-0 >= 2.54.3-4.7.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-2780
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • gio-branding-upstream >= 2.54.3-4.7.1
  • glib2 >= 2.54.3-4.7.1
  • glib2-devel-static >= 2.54.3-4.7.1
  • libgio-fam >= 2.54.3-4.7.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2018-2780
SUSE Linux Enterprise Module for additional PackageHub packages 15
  • glib2 >= 2.54.3-4.7.1
  • glib2-devel-32bit >= 2.54.3-4.7.1
  • glib2-tools-32bit >= 2.54.3-4.7.1
  • libgthread-2_0-0-32bit >= 2.54.3-4.7.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-2018-2780
SUSE Linux Enterprise Server 11 SP4
  • glib2 >= 2.22.5-0.8.36.1
  • glib2-doc >= 2.22.5-0.8.36.1
  • glib2-lang >= 2.22.5-0.8.36.1
  • libgio-2_0-0 >= 2.22.5-0.8.36.1
  • libgio-2_0-0-32bit >= 2.22.5-0.8.36.1
  • libgio-2_0-0-x86 >= 2.22.5-0.8.36.1
  • libglib-2_0-0 >= 2.22.5-0.8.36.1
  • libglib-2_0-0-32bit >= 2.22.5-0.8.36.1
  • libglib-2_0-0-x86 >= 2.22.5-0.8.36.1
  • libgmodule-2_0-0 >= 2.22.5-0.8.36.1
  • libgmodule-2_0-0-32bit >= 2.22.5-0.8.36.1
  • libgmodule-2_0-0-x86 >= 2.22.5-0.8.36.1
  • libgobject-2_0-0 >= 2.22.5-0.8.36.1
  • libgobject-2_0-0-32bit >= 2.22.5-0.8.36.1
  • libgobject-2_0-0-x86 >= 2.22.5-0.8.36.1
  • libgthread-2_0-0 >= 2.22.5-0.8.36.1
  • libgthread-2_0-0-32bit >= 2.22.5-0.8.36.1
  • libgthread-2_0-0-x86 >= 2.22.5-0.8.36.1
Patchnames:
slessp4-glib2-13889
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • glib2 >= 2.22.5-0.8.36.1
  • glib2-doc >= 2.22.5-0.8.36.1
  • glib2-lang >= 2.22.5-0.8.36.1
  • libgio-2_0-0 >= 2.22.5-0.8.36.1
  • libgio-2_0-0-32bit >= 2.22.5-0.8.36.1
  • libgio-2_0-0-x86 >= 2.22.5-0.8.36.1
  • libglib-2_0-0 >= 2.22.5-0.8.36.1
  • libglib-2_0-0-32bit >= 2.22.5-0.8.36.1
  • libglib-2_0-0-x86 >= 2.22.5-0.8.36.1
  • libgmodule-2_0-0 >= 2.22.5-0.8.36.1
  • libgmodule-2_0-0-32bit >= 2.22.5-0.8.36.1
  • libgmodule-2_0-0-x86 >= 2.22.5-0.8.36.1
  • libgobject-2_0-0 >= 2.22.5-0.8.36.1
  • libgobject-2_0-0-32bit >= 2.22.5-0.8.36.1
  • libgobject-2_0-0-x86 >= 2.22.5-0.8.36.1
  • libgthread-2_0-0 >= 2.22.5-0.8.36.1
  • libgthread-2_0-0-32bit >= 2.22.5-0.8.36.1
  • libgthread-2_0-0-x86 >= 2.22.5-0.8.36.1
Patchnames:
slessp4-glib2-13889
SUSE Linux Enterprise Software Development Kit 11 SP4
  • glib2 >= 2.22.5-0.8.36.1
  • glib2-devel >= 2.22.5-0.8.36.1
  • glib2-devel-32bit >= 2.22.5-0.8.36.1
  • glib2-doc >= 2.22.5-0.8.36.1
  • libgio-fam >= 2.22.5-0.8.36.1
Patchnames:
sdksp4-glib2-13889
SUSE Studio Onsite 1.3
  • glib2 >= 2.22.5-0.8.36.1
  • glib2-branding-upstream >= 2.22.5-0.8.36.1
  • glib2-devel >= 2.22.5-0.8.36.1
Patchnames:
slestso13-glib2-13889
openSUSE Leap 15.0
  • gio-branding-upstream >= 2.54.3-lp150.3.3.1
  • glib2 >= 2.54.3-lp150.3.3.1
  • glib2-debugsource >= 2.54.3-lp150.3.3.1
  • glib2-devel >= 2.54.3-lp150.3.3.1
  • glib2-devel-32bit >= 2.54.3-lp150.3.3.1
  • glib2-devel-32bit-debuginfo >= 2.54.3-lp150.3.3.1
  • glib2-devel-debuginfo >= 2.54.3-lp150.3.3.1
  • glib2-devel-static >= 2.54.3-lp150.3.3.1
  • glib2-lang >= 2.54.3-lp150.3.3.1
  • glib2-tools >= 2.54.3-lp150.3.3.1
  • glib2-tools-32bit >= 2.54.3-lp150.3.3.1
  • glib2-tools-32bit-debuginfo >= 2.54.3-lp150.3.3.1
  • glib2-tools-debuginfo >= 2.54.3-lp150.3.3.1
  • libgio-2_0-0 >= 2.54.3-lp150.3.3.1
  • libgio-2_0-0-32bit >= 2.54.3-lp150.3.3.1
  • libgio-2_0-0-32bit-debuginfo >= 2.54.3-lp150.3.3.1
  • libgio-2_0-0-debuginfo >= 2.54.3-lp150.3.3.1
  • libgio-fam >= 2.54.3-lp150.3.3.1
  • libgio-fam-32bit >= 2.54.3-lp150.3.3.1
  • libgio-fam-32bit-debuginfo >= 2.54.3-lp150.3.3.1
  • libgio-fam-debuginfo >= 2.54.3-lp150.3.3.1
  • libglib-2_0-0 >= 2.54.3-lp150.3.3.1
  • libglib-2_0-0-32bit >= 2.54.3-lp150.3.3.1
  • libglib-2_0-0-32bit-debuginfo >= 2.54.3-lp150.3.3.1
  • libglib-2_0-0-debuginfo >= 2.54.3-lp150.3.3.1
  • libgmodule-2_0-0 >= 2.54.3-lp150.3.3.1
  • libgmodule-2_0-0-32bit >= 2.54.3-lp150.3.3.1
  • libgmodule-2_0-0-32bit-debuginfo >= 2.54.3-lp150.3.3.1
  • libgmodule-2_0-0-debuginfo >= 2.54.3-lp150.3.3.1
  • libgobject-2_0-0 >= 2.54.3-lp150.3.3.1
  • libgobject-2_0-0-32bit >= 2.54.3-lp150.3.3.1
  • libgobject-2_0-0-32bit-debuginfo >= 2.54.3-lp150.3.3.1
  • libgobject-2_0-0-debuginfo >= 2.54.3-lp150.3.3.1
  • libgthread-2_0-0 >= 2.54.3-lp150.3.3.1
  • libgthread-2_0-0-32bit >= 2.54.3-lp150.3.3.1
  • libgthread-2_0-0-32bit-debuginfo >= 2.54.3-lp150.3.3.1
  • libgthread-2_0-0-debuginfo >= 2.54.3-lp150.3.3.1
Patchnames:
openSUSE-2018-1485


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 glib2 In progress
CaaS Platform 3.0 glib2 In progress
OpenStack Cloud Magnum Orchestration 7.0 glib2 In progress
SUSE Linux Enterprise BSK 12 SP3 glib2 In progress
SUSE Linux Enterprise BSK 12 SP4 glib2 In progress
SUSE Linux Enterprise Desktop 12 SP3 glib2 In progress
SUSE Linux Enterprise Desktop 12 SP4 glib2 In progress
SUSE Linux Enterprise High Performance Computing 12 glib2 In progress
SUSE Linux Enterprise Module for Basesystem 15 GA glib2 Released
SUSE Linux Enterprise SDK 11 SP4 glib Not affected
SUSE Linux Enterprise SDK 11 SP4 glib2 Released
SUSE Linux Enterprise SDK 12 SP3 glib2 In progress
SUSE Linux Enterprise SDK 12 SP4 glib2 In progress
SUSE Linux Enterprise Server 11 SP3 LTSS glib2 Affected
SUSE Linux Enterprise Server 11 SP4 glib2 Released
SUSE Linux Enterprise Server 12 GA LTSS glib2 Affected
SUSE Linux Enterprise Server 12 SP1 LTSS glib2 Affected
SUSE Linux Enterprise Server 12 SP2 LTSS glib2 Affected
SUSE Linux Enterprise Server 12 SP3 glib2 In progress
SUSE Linux Enterprise Server 12 SP4 glib2 In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP4 glib2 In progress
SUSE Linux Enterprise Workstation Extension 12 SP3 glib2 In progress
SUSE Linux Enterprise Workstation Extension 12 SP4 glib2 In progress
SUSE Manager Server 3.0 glib2 In progress
SUSE Studio Onsite 1.3 glib Not affected
SUSE Studio Onsite 1.3 glib2 Released