Upstream information

CVE-2018-10856 at MITRE

Description

It has been discovered that podman before version 0.6.1 does not drop capabilities when executing a container as a non-root user. This results in unnecessary privileges being granted to the container.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 5.3
Vector AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Access Vector Network Local
Access Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High Low
SUSE Bugzilla entry: 1097970 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform 3.0
  • podman >= 0.8.5-3.3.1
Patchnames:
SUSE-CAASP-3.0-2018-1896
SUSE Linux Enterprise Module for Containers 15 SP1
  • podman >= 1.0.1-2.20
  • podman-cni-config >= 1.0.1-2.20
Patchnames:
SUSE Linux Enterprise Module for Containers 15 SP1 GA podman


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 3.0 podman Released