Upstream information

CVE-2017-5884 at MITRE

Description

gtk-vnc before 0.7.0 does not properly check boundaries of subrectangle-containing tiles, which allows remote servers to execute arbitrary code via the src x, y coordinates in a crafted (1) rre, (2) hextile, or (3) copyrect tile.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 4.3
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial None
Integrity Impact Partial None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1024266 [IN_PROGRESS]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • libgtk-vnc-2_0-0 >= 1.0.0-2.35
  • libgvnc-1_0-0 >= 1.0.0-2.35
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libgtk-vnc-2_0-0 >= 0.7.2-1.33
  • libgvnc-1_0-0 >= 0.7.2-1.33
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • gtk-vnc-devel >= 1.0.0-2.35
  • libgvncpulse-1_0-0 >= 1.0.0-2.35
  • typelib-1_0-GVnc-1_0 >= 1.0.0-2.35
  • typelib-1_0-GVncPulse-1_0 >= 1.0.0-2.35
  • typelib-1_0-GtkVnc-1_0 >= 0.7.2-1.32
  • typelib-1_0-GtkVnc-2_0 >= 1.0.0-2.35
SUSE Linux Enterprise Module for Server Applications 15
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • gtk-vnc-devel >= 0.7.2-1.33
  • libgvncpulse-1_0-0 >= 0.7.2-1.33
  • typelib-1_0-GVnc-1_0 >= 0.7.2-1.33
  • typelib-1_0-GVncPulse-1_0 >= 0.7.2-1.33
  • typelib-1_0-GtkVnc-1_0 >= 0.7.2-1.32
  • typelib-1_0-GtkVnc-2_0 >= 0.7.2-1.33
openSUSE Leap 15.0
  • gtk-vnc-lang >= 0.7.2-lp150.1.15
  • libgtk-vnc-2_0-0 >= 0.7.2-lp150.1.15
  • libgvnc-1_0-0 >= 0.7.2-lp150.1.15
  • typelib-1_0-GVnc-1_0 >= 0.7.2-lp150.1.15
  • typelib-1_0-GtkVnc-2_0 >= 0.7.2-lp150.1.15
Patchnames:
openSUSE Leap 15.0 GA gtk-vnc-lang


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 gtk-vnc Affected
SUSE Linux Enterprise Desktop 12 SP1 gtk-vnc2 Affected
SUSE Linux Enterprise Desktop 12 SP2 gtk-vnc Affected
SUSE Linux Enterprise Desktop 12 SP2 gtk-vnc2 Affected
SUSE Linux Enterprise Point of Service 11 SP3 gtk-vnc In progress
SUSE Linux Enterprise Server 11 SP2 for VMware gtk-vnc Affected
SUSE Linux Enterprise Server 11 SP4 gtk-vnc In progress
SUSE Linux Enterprise Server 11 SP4 LTSS gtk-vnc In progress
SUSE Linux Enterprise Server 12 gtk-vnc Affected
SUSE Linux Enterprise Server 12 gtk-vnc2 Affected
SUSE Linux Enterprise Server 12 SP1 gtk-vnc Affected
SUSE Linux Enterprise Server 12 SP1 gtk-vnc2 Affected
SUSE Linux Enterprise Server 12 SP2 gtk-vnc Affected
SUSE Linux Enterprise Server 12 SP2 gtk-vnc2 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 gtk-vnc Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 gtk-vnc2 Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 gtk-vnc In progress
SUSE Linux Enterprise Software Development Kit 12 gtk-vnc Affected
SUSE Linux Enterprise Software Development Kit 12 gtk-vnc2 Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 gtk-vnc Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 gtk-vnc2 Affected
SUSE Linux Enterprise Workstation Extension 12 gtk-vnc Affected
SUSE Linux Enterprise Workstation Extension 12 SP1 gtk-vnc Affected
SUSE Linux Enterprise Workstation Extension 12 SP2 gtk-vnc Affected