Upstream information

CVE-2017-15107 at MITRE

Description

A vulnerability was found in the implementation of DNSSEC in Dnsmasq up to and including 2.78. Wildcard synthesized NSEC records could be improperly interpreted to prove the non-existence of hostnames that actually exist.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.4
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:L/A:L
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Changed
Confidentiality Impact None None
Integrity Impact High Low
Availability Impact None Low
SUSE Bugzilla entry: 1076958 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • dnsmasq >= 2.78-18.6.1
  • dnsmasq-utils >= 2.78-18.6.1
Patchnames:
HPE-Helion-OpenStack-8-2019-1721
SUSE Linux Enterprise Desktop 12 SP3
  • dnsmasq >= 2.78-18.6.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2019-1721
SUSE Linux Enterprise Desktop 12 SP4
  • dnsmasq >= 2.78-18.6.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-1721
SUSE Linux Enterprise Server 12 SP3
  • dnsmasq >= 2.78-18.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-1721
SUSE Linux Enterprise Server 12 SP4
  • dnsmasq >= 2.78-18.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1721
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • dnsmasq >= 2.78-18.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-1721
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • dnsmasq >= 2.78-18.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1721
SUSE OpenStack Cloud 7
  • dnsmasq >= 2.78-18.6.1
  • dnsmasq-utils >= 2.78-18.6.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-1721
SUSE OpenStack Cloud 8
  • dnsmasq >= 2.78-18.6.1
  • dnsmasq-utils >= 2.78-18.6.1
Patchnames:
SUSE-OpenStack-Cloud-8-2019-1721
SUSE OpenStack Cloud Crowbar 8
  • dnsmasq >= 2.78-18.6.1
  • dnsmasq-utils >= 2.78-18.6.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-1721

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Server 11 SP4-LTSS
  • dnsmasq >= 2.78-0.17.10.1
SUSE Linux Enterprise Server for SAP Applications 11 SP4-LTSS
  • dnsmasq >= 2.78-0.17.10.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 dnsmasq Released
SUSE Linux Enterprise Desktop 12 SP2 dnsmasq Affected
SUSE Linux Enterprise Desktop 12 SP3 dnsmasq Released
SUSE Linux Enterprise Desktop 12 SP4 dnsmasq Released
SUSE Linux Enterprise High Performance Computing 12 dnsmasq Released
SUSE Linux Enterprise Module for Basesystem 15 GA dnsmasq In progress
SUSE Linux Enterprise Server 11 SP3 LTSS dnsmasq Affected
SUSE Linux Enterprise Server 11 SP4 dnsmasq Affected
SUSE Linux Enterprise Server 11 SP4 LTSS dnsmasq In progress
SUSE Linux Enterprise Server 12 SP1 LTSS dnsmasq Released
SUSE Linux Enterprise Server 12 SP2 dnsmasq Ignore
SUSE Linux Enterprise Server 12 SP3 dnsmasq Released
SUSE Linux Enterprise Server 12 SP4 dnsmasq Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 dnsmasq Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 dnsmasq Released
SUSE Openstack Cloud 6 dnsmasq Ignore
SUSE Openstack Cloud 7 dnsmasq Released
SUSE Openstack Cloud 8 dnsmasq Released
SUSE Openstack Cloud 9 dnsmasq Released