Upstream information

CVE-2017-14604 at MITRE

Description

GNOME Nautilus before 3.23.90 allows attackers to spoof a file type by using the .desktop file extension, as demonstrated by an attack in which a .desktop file's Name field ends in .pdf but this file's Exec field launches a malicious "sh -c" command. In other words, Nautilus provides no UI indication that a file actually has the potentially unsafe .desktop extension; instead, the UI only shows the .pdf extension. One (slightly) mitigating factor is that an attack requires the .desktop file to have execute permission. The solution is to ask the user to confirm that the file is supposed to be treated as a .desktop file, and then remember the user's answer in the metadata::trusted field.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4 4.6
Vector AV:N/AC:L/Au:S/C:N/I:P/A:N AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network Local
Access Complexity Low Low
Authentication Single None
Confidentiality Impact None Partial
Integrity Impact Partial Partial
Availability Impact None Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 4.8
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L
Attack Vector Network Local
Attack Complexity Low Low
Privileges Required Low Low
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact None Low
Integrity Impact High Low
Availability Impact None Low
CVSSv3 Version 3.1 3
SUSE Bugzilla entry: 1060031 [CONFIRMED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • nautilus-devel >= 2.28.4-1.16.21.3.1
Patchnames:
sdksp4-nautilus-13654
SUSE Linux Enterprise Desktop 12 SP3
  • gnome-shell-search-provider-nautilus >= 3.20.3-23.3.14
  • libnautilus-extension1 >= 3.20.3-23.3.14
  • libnautilus-extension1-32bit >= 3.20.3-23.3.14
  • nautilus >= 3.20.3-23.3.14
  • nautilus-devel >= 3.20.3-23.3.14
  • nautilus-lang >= 3.20.3-23.3.14
  • typelib-1_0-Nautilus-3_0 >= 3.20.3-23.3.14
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1387
SUSE-SLE-SDK-12-SP3-2018-1387
SUSE-SLE-WE-12-SP3-2018-1387
SUSE Linux Enterprise Desktop 12 SP4
  • gnome-shell-search-provider-nautilus >= 3.20.3-23.6.1
  • libnautilus-extension1 >= 3.20.3-23.6.1
  • libnautilus-extension1-32bit >= 3.20.3-23.6.1
  • nautilus >= 3.20.3-23.6.1
  • nautilus-devel >= 3.20.3-23.6.1
  • nautilus-lang >= 3.20.3-23.6.1
  • typelib-1_0-Nautilus-3_0 >= 3.20.3-23.6.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA gnome-shell-search-provider-nautilus-3.20.3-23.6.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA nautilus-devel-3.20.3-23.6.1
SUSE Linux Enterprise Workstation Extension 12 SP4 GA libnautilus-extension1-32bit-3.20.3-23.6.1
SUSE Linux Enterprise High Performance Computing 12 SP5
  • gnome-shell-search-provider-nautilus >= 3.20.3-23.12.10
  • libnautilus-extension1 >= 3.20.3-23.12.10
  • nautilus >= 3.20.3-23.12.10
  • nautilus-lang >= 3.20.3-23.12.10
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA gnome-shell-search-provider-nautilus-3.20.3-23.12.10
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • nautilus >= 2.28.4-1.16.21.3.1
  • nautilus-32bit >= 2.28.4-1.16.21.3.1
  • nautilus-devel >= 2.28.4-1.16.21.3.1
  • nautilus-lang >= 2.28.4-1.16.21.3.1
  • nautilus-x86 >= 2.28.4-1.16.21.3.1
Patchnames:
sdksp4-nautilus-13654
slessp4-nautilus-13654
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • gnome-shell-search-provider-nautilus >= 3.20.3-23.3.14
  • libnautilus-extension1 >= 3.20.3-23.3.14
  • libnautilus-extension1-32bit >= 3.20.3-23.3.14
  • nautilus >= 3.20.3-23.3.14
  • nautilus-devel >= 3.20.3-23.3.14
  • nautilus-lang >= 3.20.3-23.3.14
  • typelib-1_0-Nautilus-3_0 >= 3.20.3-23.3.14
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1387
SUSE-SLE-SERVER-12-SP3-2018-1387
SUSE-SLE-WE-12-SP3-2018-1387
SUSE Linux Enterprise Server 12 SP4
  • gnome-shell-search-provider-nautilus >= 3.20.3-23.6.1
  • libnautilus-extension1 >= 3.20.3-23.6.1
  • libnautilus-extension1-32bit >= 3.20.3-23.6.1
  • nautilus >= 3.20.3-23.6.1
  • nautilus-devel >= 3.20.3-23.6.1
  • nautilus-lang >= 3.20.3-23.6.1
  • typelib-1_0-Nautilus-3_0 >= 3.20.3-23.6.1
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA gnome-shell-search-provider-nautilus-3.20.3-23.6.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA nautilus-devel-3.20.3-23.6.1
SUSE Linux Enterprise Workstation Extension 12 SP4 GA libnautilus-extension1-32bit-3.20.3-23.6.1
SUSE Linux Enterprise Server 12 SP5
  • gnome-shell-search-provider-nautilus >= 3.20.3-23.12.10
  • libnautilus-extension1 >= 3.20.3-23.12.10
  • libnautilus-extension1-32bit >= 3.20.3-23.12.10
  • nautilus >= 3.20.3-23.12.10
  • nautilus-devel >= 3.20.3-23.12.10
  • nautilus-lang >= 3.20.3-23.12.10
  • typelib-1_0-Nautilus-3_0 >= 3.20.3-23.12.10
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA gnome-shell-search-provider-nautilus-3.20.3-23.12.10
SUSE Linux Enterprise Software Development Kit 12 SP5 GA nautilus-devel-3.20.3-23.12.10
SUSE Linux Enterprise Workstation Extension 12 SP5 GA libnautilus-extension1-32bit-3.20.3-23.12.10
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libnautilus-extension1-32bit >= 3.20.3-23.6.1
  • nautilus-devel >= 3.20.3-23.6.1
  • typelib-1_0-Nautilus-3_0 >= 3.20.3-23.6.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA nautilus-devel-3.20.3-23.6.1
SUSE Linux Enterprise Workstation Extension 12 SP4 GA libnautilus-extension1-32bit-3.20.3-23.6.1
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libnautilus-extension1-32bit >= 3.20.3-23.12.10
  • nautilus-devel >= 3.20.3-23.12.10
  • typelib-1_0-Nautilus-3_0 >= 3.20.3-23.12.10
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA nautilus-devel-3.20.3-23.12.10
SUSE Linux Enterprise Workstation Extension 12 SP5 GA libnautilus-extension1-32bit-3.20.3-23.12.10
SUSE Linux Enterprise Software Development Kit 12 SP3
  • nautilus-devel >= 3.20.3-23.3.14
  • typelib-1_0-Nautilus-3_0 >= 3.20.3-23.3.14
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1387
SUSE Linux Enterprise Software Development Kit 12 SP4
  • nautilus-devel >= 3.20.3-23.6.1
  • typelib-1_0-Nautilus-3_0 >= 3.20.3-23.6.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA nautilus-devel-3.20.3-23.6.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • nautilus-devel >= 3.20.3-23.12.10
  • typelib-1_0-Nautilus-3_0 >= 3.20.3-23.12.10
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA nautilus-devel-3.20.3-23.12.10
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libnautilus-extension1-32bit >= 3.20.3-23.3.14
Patchnames:
SUSE-SLE-WE-12-SP3-2018-1387
SUSE Linux Enterprise Workstation Extension 12 SP4
  • libnautilus-extension1-32bit >= 3.20.3-23.6.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP4 GA libnautilus-extension1-32bit-3.20.3-23.6.1
SUSE Linux Enterprise Workstation Extension 12 SP5
  • libnautilus-extension1-32bit >= 3.20.3-23.12.10
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP5 GA libnautilus-extension1-32bit-3.20.3-23.12.10


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise High Performance Computing 12 SP5 nautilus Released
SUSE Linux Enterprise Server 12 SP5 nautilus Released
SUSE Linux Enterprise Server 12-LTSS nautilus Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP5 nautilus Released
SUSE Linux Enterprise Software Development Kit 12 SP5 nautilus Affected
SUSE Linux Enterprise Workstation Extension 12 SP5 nautilus Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Server 12 SP2-BCL nautilus Affected
SUSE Linux Enterprise Server 12 SP4 nautilus Affected
SUSE Linux Enterprise Server 12 SP4-LTSS nautilus Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 nautilus Affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 nautilus Affected
SUSE Linux Enterprise Desktop 11 SP4 nautilus Released
SUSE Linux Enterprise Desktop 12 nautilus Unsupported
SUSE Linux Enterprise Desktop 12 SP1 nautilus Unsupported
SUSE Linux Enterprise Desktop 12 SP2 nautilus Affected
SUSE Linux Enterprise Desktop 12 SP3 nautilus Released
SUSE Linux Enterprise Desktop 12 SP4 nautilus Affected
SUSE Linux Enterprise Point of Service 11 SP3 nautilus Affected
SUSE Linux Enterprise Server 11 SP3 nautilus Affected
SUSE Linux Enterprise Server 11 SP3 LTSS nautilus Unsupported
SUSE Linux Enterprise Server 11 SP3-LTSS nautilus Affected
SUSE Linux Enterprise Server 11 SP4 nautilus Released
SUSE Linux Enterprise Server 11 SP4 LTSS nautilus Affected
SUSE Linux Enterprise Server 11 SP4-LTSS nautilus Released
SUSE Linux Enterprise Server 12 nautilus Unsupported
SUSE Linux Enterprise Server 12 SP1 nautilus Unsupported
SUSE Linux Enterprise Server 12 SP1-LTSS nautilus Unsupported
SUSE Linux Enterprise Server 12 SP2 nautilus Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS nautilus Affected
SUSE Linux Enterprise Server 12 SP2-LTSS nautilus Unsupported
SUSE Linux Enterprise Server 12 SP3 nautilus Released
SUSE Linux Enterprise Server 12 SP3-BCL nautilus Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS nautilus Affected
SUSE Linux Enterprise Server 12 SP3-LTSS nautilus Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS nautilus Affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 nautilus Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 nautilus Released
SUSE Linux Enterprise Server for SAP Applications 12 nautilus Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP1 nautilus Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP2 nautilus Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 nautilus Released
SUSE Linux Enterprise Software Development Kit 11 SP4 nautilus Released
SUSE Linux Enterprise Software Development Kit 12 nautilus Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP1 nautilus Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP2 nautilus Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 nautilus Released
SUSE Linux Enterprise Software Development Kit 12 SP4 nautilus Affected
SUSE Linux Enterprise Workstation Extension 12 nautilus Unsupported
SUSE Linux Enterprise Workstation Extension 12 SP1 nautilus Unsupported
SUSE Linux Enterprise Workstation Extension 12 SP2 nautilus Affected
SUSE Linux Enterprise Workstation Extension 12 SP3 nautilus Released
SUSE Linux Enterprise Workstation Extension 12 SP4 nautilus Affected
SUSE OpenStack Cloud 7 nautilus Affected
SUSE OpenStack Cloud 8 nautilus Affected
SUSE OpenStack Cloud 9 nautilus Affected
SUSE OpenStack Cloud Crowbar 8 nautilus Affected
SUSE OpenStack Cloud Crowbar 9 nautilus Affected


SUSE Timeline for this CVE

CVE page created: Wed Sep 20 11:15:12 2017
CVE page last modified: Fri Jan 20 13:52:08 2023