Upstream information

CVE-2016-5823 at MITRE

Description

The icalproperty_new_clone function in libical 0.47 and 1.0 allows remote attackers to cause a denial of service (use-after-free) via a crafted ics file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 6.8
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact None Partial
Integrity Impact None Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.5
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Attack Vector Local
Attack Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 986632 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libical-devel >= 0.43-1.10.6.1
  • libical0-32bit >= 0.43-1.10.6.1
Patchnames:
sdksp4-libical-13417
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libical-devel >= 0.43-1.10.6.1
  • libical0 >= 0.43-1.10.6.1
  • libical0-32bit >= 0.43-1.10.6.1
Patchnames:
sdksp4-libical-13417
slessp4-libical-13417


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise High Performance Computing 12 SP5 libical Released
SUSE Linux Enterprise Server 12 SP5 libical Released
SUSE Linux Enterprise Server 12-LTSS libical Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libical Released
SUSE Linux Enterprise Software Development Kit 12 SP5 libical Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 12 SP4 libical Not affected
SUSE Linux Enterprise High Performance Computing 15 libical Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 libical Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS libical Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS libical Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS libical Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS libical Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 libical Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 libical Not affected
SUSE Linux Enterprise Server 12 SP2-BCL libical Released
SUSE Linux Enterprise Server 12 SP4 libical Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS libical Released
SUSE Linux Enterprise Server 15 SP1 libical Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS libical Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libical Released
SUSE Linux Enterprise Server for SAP Applications 15 libical Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libical Not affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 libical Released
SUSE CaaS Platform 4.0 libical Not affected
SUSE Enterprise Storage 5 libical Released
SUSE Enterprise Storage 6 libical Not affected
SUSE Linux Enterprise Desktop 11 SP4 libical Released
SUSE Linux Enterprise Desktop 12 libical Not affected
SUSE Linux Enterprise Desktop 12 SP1 libical Not affected
SUSE Linux Enterprise Desktop 12 SP2 libical Affected
SUSE Linux Enterprise Desktop 12 SP3 libical Affected
SUSE Linux Enterprise Desktop 12 SP4 libical Not affected
SUSE Linux Enterprise Desktop 15 libical Not affected
SUSE Linux Enterprise Desktop 15 SP1 libical Not affected
SUSE Linux Enterprise Module for Basesystem 15 libical Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 libical Not affected
SUSE Linux Enterprise Point of Service 11 SP3 libical Affected
SUSE Linux Enterprise Point of Service Image Server 12 SP2 libical Released
SUSE Linux Enterprise Server 11 SP2 LTSS libical Unsupported
SUSE Linux Enterprise Server 11 SP3 libical Affected
SUSE Linux Enterprise Server 11 SP3 LTSS libical Unsupported
SUSE Linux Enterprise Server 11 SP3-LTSS libical Affected
SUSE Linux Enterprise Server 11 SP4 libical Released
SUSE Linux Enterprise Server 11 SP4 LTSS libical Affected
SUSE Linux Enterprise Server 11 SP4-LTSS libical Released
SUSE Linux Enterprise Server 12 libical Not affected
SUSE Linux Enterprise Server 12 SP1 libical Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS libical Not affected
SUSE Linux Enterprise Server 12 SP2 libical Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS libical Released
SUSE Linux Enterprise Server 12 SP2-LTSS libical Released
SUSE Linux Enterprise Server 12 SP3 libical Affected
SUSE Linux Enterprise Server 12 SP3-BCL libical Released
SUSE Linux Enterprise Server 12 SP3-ESPOS libical Released
SUSE Linux Enterprise Server 12 SP3-LTSS libical Released
SUSE Linux Enterprise Server 12 SP4-ESPOS libical Released
SUSE Linux Enterprise Server 15 libical Not affected
SUSE Linux Enterprise Server 15 SP1-BCL libical Not affected
SUSE Linux Enterprise Server 15-LTSS libical Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 libical Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 libical Released
SUSE Linux Enterprise Server for SAP Applications 12 libical Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 libical Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libical Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libical Released
SUSE Linux Enterprise Software Development Kit 11 SP4 libical Released
SUSE Linux Enterprise Software Development Kit 12 libical Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 libical Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 libical Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 libical Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 libical Not affected
SUSE Manager Proxy 4.0 libical Not affected
SUSE Manager Retail Branch Server 4.0 libical Not affected
SUSE Manager Server 4.0 libical Not affected
SUSE OpenStack Cloud 7 libical Released
SUSE OpenStack Cloud 8 libical Released
SUSE OpenStack Cloud 9 libical Released
SUSE OpenStack Cloud Crowbar 8 libical Released
SUSE OpenStack Cloud Crowbar 9 libical Released


SUSE Timeline for this CVE

CVE page created: Sat Jun 25 16:15:17 2016
CVE page last modified: Fri Jan 20 13:05:22 2023