Upstream information

CVE-2016-5018 at MITRE

Description

In Apache Tomcat 9.0.0.M1 to 9.0.0.M9, 8.5.0 to 8.5.4, 8.0.0.RC1 to 8.0.36, 7.0.0 to 7.0.70 and 6.0.0 to 6.0.45 a malicious web application was able to bypass a configured SecurityManager via a Tomcat utility method that was accessible to web applications.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.4 4.3
Vector AV:N/AC:L/Au:N/C:P/I:P/A:N AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial None
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.1
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact None
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1007855 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 12 SP5
  • tomcat >= 9.0.21-3.13.2
  • tomcat-admin-webapps >= 9.0.21-3.13.2
  • tomcat-docs-webapp >= 9.0.21-3.13.2
  • tomcat-el-3_0-api >= 9.0.21-3.13.2
  • tomcat-javadoc >= 9.0.21-3.13.2
  • tomcat-jsp-2_3-api >= 9.0.21-3.13.2
  • tomcat-lib >= 9.0.21-3.13.2
  • tomcat-servlet-4_0-api >= 9.0.21-3.13.2
  • tomcat-webapps >= 9.0.21-3.13.2
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA tomcat-9.0.21-3.13.2
SUSE Linux Enterprise Point of Sale 11 SP3
  • tomcat6 >= 6.0.53-0.56.1
  • tomcat6-admin-webapps >= 6.0.53-0.56.1
  • tomcat6-docs-webapp >= 6.0.53-0.56.1
  • tomcat6-javadoc >= 6.0.53-0.56.1
  • tomcat6-jsp-2_1-api >= 6.0.53-0.56.1
  • tomcat6-lib >= 6.0.53-0.56.1
  • tomcat6-servlet-2_5-api >= 6.0.53-0.56.1
  • tomcat6-webapps >= 6.0.53-0.56.1
Patchnames:
sleposp3-tomcat6-13162
SUSE Linux Enterprise Server 11 SP3-LTSS
  • tomcat6 >= 6.0.53-0.56.1
  • tomcat6-admin-webapps >= 6.0.53-0.56.1
  • tomcat6-docs-webapp >= 6.0.53-0.56.1
  • tomcat6-javadoc >= 6.0.53-0.56.1
  • tomcat6-jsp-2_1-api >= 6.0.53-0.56.1
  • tomcat6-lib >= 6.0.53-0.56.1
  • tomcat6-servlet-2_5-api >= 6.0.53-0.56.1
  • tomcat6-webapps >= 6.0.53-0.56.1
Patchnames:
slessp3-tomcat6-13162
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • tomcat6 >= 6.0.53-0.56.1
  • tomcat6-admin-webapps >= 6.0.53-0.56.1
  • tomcat6-docs-webapp >= 6.0.53-0.56.1
  • tomcat6-javadoc >= 6.0.53-0.56.1
  • tomcat6-jsp-2_1-api >= 6.0.53-0.56.1
  • tomcat6-lib >= 6.0.53-0.56.1
  • tomcat6-servlet-2_5-api >= 6.0.53-0.56.1
  • tomcat6-webapps >= 6.0.53-0.56.1
Patchnames:
slessp4-tomcat6-13162
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • tomcat >= 8.0.32-10.13.2
  • tomcat-admin-webapps >= 8.0.32-10.13.2
  • tomcat-docs-webapp >= 8.0.32-10.13.2
  • tomcat-el-3_0-api >= 8.0.32-10.13.2
  • tomcat-javadoc >= 8.0.32-10.13.2
  • tomcat-jsp-2_3-api >= 8.0.32-10.13.2
  • tomcat-lib >= 8.0.32-10.13.2
  • tomcat-servlet-3_1-api >= 8.0.32-10.13.2
  • tomcat-webapps >= 8.0.32-10.13.2
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1791
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • tomcat >= 8.0.36-17.1
  • tomcat-admin-webapps >= 8.0.36-17.1
  • tomcat-docs-webapp >= 8.0.36-17.1
  • tomcat-el-3_0-api >= 8.0.36-17.1
  • tomcat-javadoc >= 8.0.36-17.1
  • tomcat-jsp-2_3-api >= 8.0.36-17.1
  • tomcat-lib >= 8.0.36-17.1
  • tomcat-servlet-3_1-api >= 8.0.36-17.1
  • tomcat-webapps >= 8.0.36-17.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2016-1790
SUSE Linux Enterprise Server 12 SP3
  • tomcat >= 8.0.43-23.1
  • tomcat-admin-webapps >= 8.0.43-23.1
  • tomcat-docs-webapp >= 8.0.43-23.1
  • tomcat-el-3_0-api >= 8.0.43-23.1
  • tomcat-javadoc >= 8.0.43-23.1
  • tomcat-jsp-2_3-api >= 8.0.43-23.1
  • tomcat-lib >= 8.0.43-23.1
  • tomcat-servlet-3_1-api >= 8.0.43-23.1
  • tomcat-webapps >= 8.0.43-23.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA tomcat-8.0.43-23.1
SUSE Linux Enterprise Server 12 SP4
  • tomcat >= 9.0.12-1.7
  • tomcat-admin-webapps >= 9.0.12-1.7
  • tomcat-docs-webapp >= 9.0.12-1.7
  • tomcat-el-3_0-api >= 9.0.12-1.7
  • tomcat-javadoc >= 9.0.12-1.7
  • tomcat-jsp-2_3-api >= 9.0.12-1.7
  • tomcat-lib >= 9.0.12-1.7
  • tomcat-servlet-4_0-api >= 9.0.12-1.7
  • tomcat-webapps >= 9.0.12-1.7
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA tomcat-9.0.12-1.7
SUSE Linux Enterprise Server 12 SP5
  • tomcat >= 9.0.21-3.13.2
  • tomcat-admin-webapps >= 9.0.21-3.13.2
  • tomcat-docs-webapp >= 9.0.21-3.13.2
  • tomcat-el-3_0-api >= 9.0.21-3.13.2
  • tomcat-javadoc >= 9.0.21-3.13.2
  • tomcat-jsp-2_3-api >= 9.0.21-3.13.2
  • tomcat-lib >= 9.0.21-3.13.2
  • tomcat-servlet-4_0-api >= 9.0.21-3.13.2
  • tomcat-webapps >= 9.0.21-3.13.2
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA tomcat-9.0.21-3.13.2
SUSE Linux Enterprise Server 12-LTSS
  • tomcat >= 7.0.78-7.13.4
  • tomcat-admin-webapps >= 7.0.78-7.13.4
  • tomcat-docs-webapp >= 7.0.78-7.13.4
  • tomcat-el-2_2-api >= 7.0.78-7.13.4
  • tomcat-javadoc >= 7.0.78-7.13.4
  • tomcat-jsp-2_2-api >= 7.0.78-7.13.4
  • tomcat-lib >= 7.0.78-7.13.4
  • tomcat-servlet-3_0-api >= 7.0.78-7.13.4
  • tomcat-webapps >= 7.0.78-7.13.4
Patchnames:
SUSE-SLE-SERVER-12-2017-1027
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • tomcat >= 8.0.36-17.1
  • tomcat-admin-webapps >= 8.0.36-17.1
  • tomcat-docs-webapp >= 8.0.36-17.1
  • tomcat-el-3_0-api >= 8.0.36-17.1
  • tomcat-javadoc >= 8.0.36-17.1
  • tomcat-jsp-2_3-api >= 8.0.36-17.1
  • tomcat-lib >= 8.0.36-17.1
  • tomcat-servlet-3_1-api >= 8.0.36-17.1
  • tomcat-webapps >= 8.0.36-17.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2016-1790
SUSE Linux Enterprise Server for SAP Applications 12
  • tomcat >= 7.0.78-7.13.4
  • tomcat-admin-webapps >= 7.0.78-7.13.4
  • tomcat-docs-webapp >= 7.0.78-7.13.4
  • tomcat-el-2_2-api >= 7.0.78-7.13.4
  • tomcat-javadoc >= 7.0.78-7.13.4
  • tomcat-jsp-2_2-api >= 7.0.78-7.13.4
  • tomcat-lib >= 7.0.78-7.13.4
  • tomcat-servlet-3_0-api >= 7.0.78-7.13.4
  • tomcat-webapps >= 7.0.78-7.13.4
Patchnames:
SUSE-SLE-SAP-12-2017-1027


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise High Performance Computing 12 SP5 tomcat Affected
SUSE Linux Enterprise Server 12 SP5 tomcat Affected
SUSE Linux Enterprise Server 12-LTSS tomcat Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 tomcat Affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Server 12 SP2-BCL tomcat Affected
SUSE Linux Enterprise Server 12 SP4 tomcat Affected
SUSE Linux Enterprise Server 12 SP4-LTSS tomcat Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 tomcat Affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 tomcat Affected
SUSE Linux Enterprise Point of Sale 11 SP3 tomcat6 Released
SUSE Linux Enterprise Point of Service 11 SP3 tomcat6 Released
SUSE Linux Enterprise Server 11 SP3 tomcat6 Affected
SUSE Linux Enterprise Server 11 SP3 LTSS tomcat6 Released
SUSE Linux Enterprise Server 11 SP3-LTSS tomcat6 Released
SUSE Linux Enterprise Server 11 SP4 tomcat6 Released
SUSE Linux Enterprise Server 11 SP4 LTSS tomcat6 Released
SUSE Linux Enterprise Server 11 SP4-LTSS tomcat6 Released
SUSE Linux Enterprise Server 12 tomcat Affected
SUSE Linux Enterprise Server 12 SP1 tomcat Released
SUSE Linux Enterprise Server 12 SP1-LTSS tomcat Affected
SUSE Linux Enterprise Server 12 SP2 tomcat Released
SUSE Linux Enterprise Server 12 SP2-ESPOS tomcat Affected
SUSE Linux Enterprise Server 12 SP2-LTSS tomcat Affected
SUSE Linux Enterprise Server 12 SP3 tomcat Affected
SUSE Linux Enterprise Server 12 SP3-BCL tomcat Unsupported
SUSE Linux Enterprise Server 12 SP3-ESPOS tomcat Affected
SUSE Linux Enterprise Server 12 SP3-LTSS tomcat Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS tomcat Affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 tomcat Released
SUSE Linux Enterprise Server for SAP Applications 11 SP4 tomcat6 Released
SUSE Linux Enterprise Server for SAP Applications 12 tomcat Released
SUSE Linux Enterprise Server for SAP Applications 12 SP1 tomcat Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 tomcat Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 tomcat Affected
SUSE Linux Enterprise Server for the Raspberry Pi 12 SP2 tomcat Released
SUSE OpenStack Cloud 7 tomcat Affected
SUSE OpenStack Cloud 8 tomcat Affected
SUSE OpenStack Cloud 9 tomcat Affected
SUSE OpenStack Cloud Crowbar 8 tomcat Affected
SUSE OpenStack Cloud Crowbar 9 tomcat Affected


SUSE Timeline for this CVE

CVE page created: Thu Oct 27 17:18:37 2016
CVE page last modified: Sun Jan 22 15:44:39 2023