Upstream information

CVE-2016-10249 at MITRE

Description

Integer overflow in the jpc_dec_tiledecode function in jpc_dec.c in JasPer before 1.900.12 allows remote attackers to have unspecified impact via a crafted image file, which triggers a heap-based buffer overflow.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 5.1
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:N/AC:H/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Medium High
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 5.6
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
Access Vector Local Network
Access Complexity Low High
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High Low
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1029704 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise 15 Module for Basesystem jasper Not affected
SUSE Linux Enterprise 15 Module for Desktop Applications jasper Not affected
SUSE Linux Enterprise 15-SP1 Module for Basesystem jasper Not affected
SUSE Linux Enterprise 15-SP1 Module for Desktop Applications jasper Not affected
SUSE Linux Enterprise Desktop 12 SP4 jasper Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 jasper Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 jasper Released
SUSE Linux Enterprise Server 11 SP1 jasper Not affected
SUSE Linux Enterprise Server 11 SP3 jasper Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS jasper Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS jasper Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS jasper Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS jasper Not affected
SUSE Linux Enterprise Server 12 SP4 jasper Not affected
SUSE Linux Enterprise Server 12 SP5 jasper Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 jasper Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 jasper Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 jasper Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 jasper Released
SUSE Linux Enterprise Software Development Kit 12 SP4 jasper Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 jasper Not affected