Upstream information

CVE-2016-10128 at MITRE

Description

Buffer overflow in the git_pkt_parse_line function in transports/smart_pkt.c in the Git Smart Protocol support in libgit2 before 0.24.6 and 0.25.x before 0.25.1 allows remote attackers to have unspecified impact via a crafted non-flush packet.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.8
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:P/I:N/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1019036 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Development Tools 15
  • libgit2-26 >= 0.26.3-1.26
  • libgit2-devel >= 0.26.3-1.26
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 GA libgit2-26
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libgit2 >= 0.24.1-6.1
  • libgit2-24 >= 0.24.1-6.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-220
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libgit2-24 >= 0.24.1-6.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libgit2-24
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libgit2-24 >= 0.24.1-7.6.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libgit2-24
SUSE Package Hub for SUSE Linux Enterprise 12 SP1
  • libgit2 >= 0.24.6-10.1
  • libgit2-24 >= 0.24.6-10.1
  • libgit2-devel >= 0.24.6-10.1
Patchnames:
openSUSE-2017-216
openSUSE Leap 15.0
  • libgit2-26 >= 0.26.3-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA libgit2-26
openSUSE Leap 42.1
  • libgit2 >= 0.22.1-8.1
  • libgit2-22 >= 0.22.1-8.1
  • libgit2-22-32bit >= 0.22.1-8.1
  • libgit2-22-debuginfo >= 0.22.1-8.1
  • libgit2-22-debuginfo-32bit >= 0.22.1-8.1
  • libgit2-debugsource >= 0.22.1-8.1
  • libgit2-devel >= 0.22.1-8.1
Patchnames:
openSUSE-2017-213
openSUSE Leap 42.2
  • libgit2 >= 0.24.1-6.1
  • libgit2-24 >= 0.24.1-6.1
  • libgit2-24-32bit >= 0.24.1-6.1
  • libgit2-24-debuginfo >= 0.24.1-6.1
  • libgit2-24-debuginfo-32bit >= 0.24.1-6.1
  • libgit2-debugsource >= 0.24.1-6.1
  • libgit2-devel >= 0.24.1-6.1
Patchnames:
openSUSE-2017-262
openSUSE Leap 42.3
  • libgit2-24 >= 0.24.1-9.16
Patchnames:
openSUSE Leap 42.3 GA libgit2-24


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 12 SP2 libgit2 Released