Upstream information

CVE-2015-8737 at MITRE

Description

The mp2t_open function in wiretap/mp2t.c in the MP2T file parser in Wireshark 2.0.x before 2.0.1 does not validate the bit rate, which allows remote attackers to cause a denial of service (divide-by-zero error and application crash) via a crafted file.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
No SUSE Bugzilla entries cross referenced.

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 6
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • libwireshark9 >= 2.4.14-3.25.2
  • libwiretap7 >= 2.4.14-3.25.2
  • libwscodecs1 >= 2.4.14-3.25.2
  • libwsutil8 >= 2.4.14-3.25.2
  • wireshark >= 2.4.14-3.25.2
  • wireshark-devel >= 2.4.14-3.25.2
  • wireshark-ui-qt >= 2.4.14-3.25.2
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libwireshark9-2.4.14-3.25.2
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 GA wireshark-devel-2.4.14-3.25.2
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • libwireshark13 >= 3.2.8-3.44.1
  • libwiretap10 >= 3.2.8-3.44.1
  • libwscodecs1 >= 2.4.16-3.31.1
  • libwsutil11 >= 3.2.8-3.44.1
  • libwsutil8 >= 2.4.16-3.31.1
  • wireshark >= 3.2.8-3.44.1
  • wireshark-devel >= 3.2.8-3.44.1
  • wireshark-ui-qt >= 3.2.8-3.44.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA libwireshark13-3.2.8-3.44.1
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA libwscodecs1-2.4.16-3.31.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 GA wireshark-devel-3.2.8-3.44.1
SUSE Enterprise Storage 7
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • libwireshark13 >= 3.2.2-3.35.2
  • libwiretap10 >= 3.2.2-3.35.2
  • libwscodecs1 >= 2.4.16-3.31.1
  • libwsutil11 >= 3.2.2-3.35.2
  • libwsutil8 >= 2.4.16-3.31.1
  • wireshark >= 3.2.2-3.35.2
  • wireshark-devel >= 3.2.2-3.35.2
  • wireshark-ui-qt >= 3.2.2-3.35.2
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA libwireshark13-3.2.2-3.35.2
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA libwscodecs1-2.4.16-3.31.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 GA wireshark-devel-3.2.2-3.35.2
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwscodecs1 >= 2.4.16-3.31.1
  • libwsutil13 >= 3.6.2-3.71.1
  • libwsutil8 >= 2.4.16-3.31.1
  • wireshark >= 3.6.2-3.71.1
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA libwireshark15-3.6.2-3.71.1
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA libwscodecs1-2.4.16-3.31.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 GA wireshark-devel-3.6.2-3.71.1
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • libwireshark9 >= 2.4.6-1.31
  • libwiretap7 >= 2.4.6-1.31
  • libwscodecs1 >= 2.4.6-1.31
  • libwsutil8 >= 2.4.6-1.31
  • wireshark >= 2.4.6-1.31
  • wireshark-devel >= 2.4.6-1.31
  • wireshark-ui-qt >= 2.4.6-1.31
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libwireshark9-2.4.6-1.31
SUSE Linux Enterprise Module for Desktop Applications 15 GA wireshark-devel-2.4.6-1.31
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libwireshark9 >= 2.4.14-3.25.2
  • libwiretap7 >= 2.4.14-3.25.2
  • libwscodecs1 >= 2.4.14-3.25.2
  • libwsutil8 >= 2.4.14-3.25.2
  • wireshark >= 2.4.14-3.25.2
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libwireshark9-2.4.14-3.25.2
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • libwireshark13 >= 3.2.2-3.35.2
  • libwiretap10 >= 3.2.2-3.35.2
  • libwscodecs1 >= 2.4.16-3.31.1
  • libwsutil11 >= 3.2.2-3.35.2
  • libwsutil8 >= 2.4.16-3.31.1
  • wireshark >= 3.2.2-3.35.2
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA libwireshark13-3.2.2-3.35.2
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA libwscodecs1-2.4.16-3.31.1
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libwireshark13 >= 3.2.8-3.44.1
  • libwiretap10 >= 3.2.8-3.44.1
  • libwscodecs1 >= 2.4.16-3.31.1
  • libwsutil11 >= 3.2.8-3.44.1
  • libwsutil8 >= 2.4.16-3.31.1
  • wireshark >= 3.2.8-3.44.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA libwireshark13-3.2.8-3.44.1
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA libwscodecs1-2.4.16-3.31.1
SUSE Linux Enterprise Module for Basesystem 15 SP4
  • libwireshark15 >= 3.6.2-3.71.1
  • libwiretap12 >= 3.6.2-3.71.1
  • libwscodecs1 >= 2.4.16-3.31.1
  • libwsutil13 >= 3.6.2-3.71.1
  • libwsutil8 >= 2.4.16-3.31.1
  • wireshark >= 3.6.2-3.71.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA libwireshark15-3.6.2-3.71.1
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA libwscodecs1-2.4.16-3.31.1
SUSE Linux Enterprise Module for Basesystem 15
  • libwireshark9 >= 2.4.6-1.31
  • libwiretap7 >= 2.4.6-1.31
  • libwscodecs1 >= 2.4.6-1.31
  • libwsutil8 >= 2.4.6-1.31
  • wireshark >= 2.4.6-1.31
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libwireshark9-2.4.6-1.31
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • wireshark-devel >= 2.4.14-3.25.2
  • wireshark-ui-qt >= 2.4.14-3.25.2
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 GA wireshark-devel-2.4.14-3.25.2
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
  • wireshark-devel >= 3.2.2-3.35.2
  • wireshark-ui-qt >= 3.2.2-3.35.2
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 GA wireshark-devel-3.2.2-3.35.2
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • wireshark-devel >= 3.2.8-3.44.1
  • wireshark-ui-qt >= 3.2.8-3.44.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 GA wireshark-devel-3.2.8-3.44.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP4
  • wireshark-devel >= 3.6.2-3.71.1
  • wireshark-ui-qt >= 3.6.2-3.71.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 GA wireshark-devel-3.6.2-3.71.1
SUSE Linux Enterprise Module for Desktop Applications 15
  • wireshark-devel >= 2.4.6-1.31
  • wireshark-ui-qt >= 2.4.6-1.31
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA wireshark-devel-2.4.6-1.31
openSUSE Tumbleweed
  • wireshark >= 2.2.2-1.1
  • wireshark-devel >= 2.2.2-1.1
  • wireshark-ui-gtk >= 2.2.2-1.1
  • wireshark-ui-qt >= 2.2.2-1.1
Patchnames:
openSUSE Tumbleweed GA wireshark-2.2.2-1.1


SUSE Timeline for this CVE

CVE page created: Mon Jan 4 09:15:51 2016
CVE page last modified: Tue Nov 8 17:35:49 2022