Upstream information

CVE-2015-7542 at MITRE

Description

A vulnerability exists in libgwenhywfar through 4.12.0 due to the usage of outdated bundled CA certificates.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.3
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact None
Availability Impact None
CVSSv3 Version 3.1
SUSE Bugzilla entry: 958331 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • gwenhywfar-devel >= 4.9.0beta-3.3.1
  • gwenhywfar-lang >= 4.9.0beta-3.3.1
  • gwenhywfar-tools >= 4.9.0beta-3.3.1
  • libgwengui-gtk2-0 >= 4.9.0beta-3.3.1
  • libgwengui-qt4-0 >= 4.9.0beta-3.3.1
  • libgwenhywfar60 >= 4.9.0beta-3.3.1
  • libgwenhywfar60-plugins >= 4.9.0beta-3.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2018-60
SUSE-SLE-SDK-12-SP2-2018-60
SUSE-SLE-WE-12-SP2-2018-60
SUSE Linux Enterprise Desktop 12 SP3
  • gwenhywfar-devel >= 4.9.0beta-3.3.1
  • gwenhywfar-lang >= 4.9.0beta-3.3.1
  • gwenhywfar-tools >= 4.9.0beta-3.3.1
  • libgwengui-gtk2-0 >= 4.9.0beta-3.3.1
  • libgwengui-qt4-0 >= 4.9.0beta-3.3.1
  • libgwenhywfar60 >= 4.9.0beta-3.3.1
  • libgwenhywfar60-plugins >= 4.9.0beta-3.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-60
SUSE-SLE-SDK-12-SP3-2018-60
SUSE-SLE-WE-12-SP3-2018-60
SUSE Linux Enterprise Desktop 12 SP4
  • gwenhywfar-devel >= 4.9.0beta-3.3.1
  • gwenhywfar-lang >= 4.9.0beta-3.3.1
  • gwenhywfar-tools >= 4.9.0beta-3.3.1
  • libgwengui-gtk2-0 >= 4.9.0beta-3.3.1
  • libgwengui-qt4-0 >= 4.9.0beta-3.3.1
  • libgwenhywfar60 >= 4.9.0beta-3.3.1
  • libgwenhywfar60-plugins >= 4.9.0beta-3.3.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA gwenhywfar-lang-4.9.0beta-3.3.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA gwenhywfar-devel-4.9.0beta-3.3.1
SUSE Linux Enterprise Workstation Extension 12 SP4 GA gwenhywfar-lang-4.9.0beta-3.3.1
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • gwenhywfar-devel >= 4.9.0beta-3.3.1
  • gwenhywfar-lang >= 4.9.0beta-3.3.1
  • gwenhywfar-tools >= 4.9.0beta-3.3.1
  • libgwengui-gtk2-0 >= 4.9.0beta-3.3.1
  • libgwengui-qt4-0 >= 4.9.0beta-3.3.1
  • libgwenhywfar60 >= 4.9.0beta-3.3.1
  • libgwenhywfar60-plugins >= 4.9.0beta-3.3.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2018-60
SUSE-SLE-WE-12-SP2-2018-60
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • gwenhywfar-devel >= 4.9.0beta-3.3.1
  • gwenhywfar-lang >= 4.9.0beta-3.3.1
  • gwenhywfar-tools >= 4.9.0beta-3.3.1
  • libgwengui-gtk2-0 >= 4.9.0beta-3.3.1
  • libgwengui-qt4-0 >= 4.9.0beta-3.3.1
  • libgwenhywfar60 >= 4.9.0beta-3.3.1
  • libgwenhywfar60-plugins >= 4.9.0beta-3.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-60
SUSE-SLE-WE-12-SP3-2018-60
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • gwenhywfar-devel >= 4.9.0beta-3.3.1
  • gwenhywfar-lang >= 4.9.0beta-3.3.1
  • gwenhywfar-tools >= 4.9.0beta-3.3.1
  • libgwengui-gtk2-0 >= 4.9.0beta-3.3.1
  • libgwengui-qt4-0 >= 4.9.0beta-3.3.1
  • libgwenhywfar60 >= 4.9.0beta-3.3.1
  • libgwenhywfar60-plugins >= 4.9.0beta-3.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA gwenhywfar-devel-4.9.0beta-3.3.1
SUSE Linux Enterprise Workstation Extension 12 SP4 GA gwenhywfar-lang-4.9.0beta-3.3.1
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • gwenhywfar-devel >= 4.9.0beta-3.3.1
  • gwenhywfar-lang >= 4.9.0beta-3.3.1
  • gwenhywfar-tools >= 4.9.0beta-3.3.1
  • libgwengui-gtk2-0 >= 4.9.0beta-3.3.1
  • libgwengui-qt4-0 >= 4.9.0beta-3.3.1
  • libgwenhywfar60 >= 4.9.0beta-3.3.1
  • libgwenhywfar60-plugins >= 4.9.0beta-3.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA gwenhywfar-devel-4.9.0beta-3.3.1
SUSE Linux Enterprise Workstation Extension 12 SP5 GA gwenhywfar-lang-4.9.0beta-3.3.1
SUSE Linux Enterprise Software Development Kit 12 SP2
  • gwenhywfar-devel >= 4.9.0beta-3.3.1
  • libgwengui-gtk2-0 >= 4.9.0beta-3.3.1
  • libgwengui-qt4-0 >= 4.9.0beta-3.3.1
  • libgwenhywfar60 >= 4.9.0beta-3.3.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2018-60
SUSE Linux Enterprise Software Development Kit 12 SP3
  • gwenhywfar-devel >= 4.9.0beta-3.3.1
  • libgwengui-gtk2-0 >= 4.9.0beta-3.3.1
  • libgwengui-qt4-0 >= 4.9.0beta-3.3.1
  • libgwenhywfar60 >= 4.9.0beta-3.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-60
SUSE Linux Enterprise Software Development Kit 12 SP4
  • gwenhywfar-devel >= 4.9.0beta-3.3.1
  • libgwengui-gtk2-0 >= 4.9.0beta-3.3.1
  • libgwengui-qt4-0 >= 4.9.0beta-3.3.1
  • libgwenhywfar60 >= 4.9.0beta-3.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA gwenhywfar-devel-4.9.0beta-3.3.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • gwenhywfar-devel >= 4.9.0beta-3.3.1
  • libgwengui-gtk2-0 >= 4.9.0beta-3.3.1
  • libgwengui-qt4-0 >= 4.9.0beta-3.3.1
  • libgwenhywfar60 >= 4.9.0beta-3.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA gwenhywfar-devel-4.9.0beta-3.3.1
SUSE Linux Enterprise Workstation Extension 12 SP2
  • gwenhywfar-lang >= 4.9.0beta-3.3.1
  • gwenhywfar-tools >= 4.9.0beta-3.3.1
  • libgwengui-gtk2-0 >= 4.9.0beta-3.3.1
  • libgwenhywfar60 >= 4.9.0beta-3.3.1
  • libgwenhywfar60-plugins >= 4.9.0beta-3.3.1
Patchnames:
SUSE-SLE-WE-12-SP2-2018-60
SUSE Linux Enterprise Workstation Extension 12 SP3
  • gwenhywfar-lang >= 4.9.0beta-3.3.1
  • gwenhywfar-tools >= 4.9.0beta-3.3.1
  • libgwengui-gtk2-0 >= 4.9.0beta-3.3.1
  • libgwenhywfar60 >= 4.9.0beta-3.3.1
  • libgwenhywfar60-plugins >= 4.9.0beta-3.3.1
Patchnames:
SUSE-SLE-WE-12-SP3-2018-60
SUSE Linux Enterprise Workstation Extension 12 SP4
  • gwenhywfar-lang >= 4.9.0beta-3.3.1
  • gwenhywfar-tools >= 4.9.0beta-3.3.1
  • libgwengui-gtk2-0 >= 4.9.0beta-3.3.1
  • libgwenhywfar60 >= 4.9.0beta-3.3.1
  • libgwenhywfar60-plugins >= 4.9.0beta-3.3.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP4 GA gwenhywfar-lang-4.9.0beta-3.3.1
SUSE Linux Enterprise Workstation Extension 12 SP5
  • gwenhywfar-lang >= 4.9.0beta-3.3.1
  • gwenhywfar-tools >= 4.9.0beta-3.3.1
  • libgwengui-gtk2-0 >= 4.9.0beta-3.3.1
  • libgwenhywfar60 >= 4.9.0beta-3.3.1
  • libgwenhywfar60-plugins >= 4.9.0beta-3.3.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP5 GA gwenhywfar-lang-4.9.0beta-3.3.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Server 12 SP5 gwenhywfar Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 gwenhywfar Released
SUSE Linux Enterprise Software Development Kit 12 SP5 gwenhywfar Released
SUSE Linux Enterprise Workstation Extension 12 SP5 gwenhywfar Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Server 12 SP4 gwenhywfar Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 gwenhywfar Affected
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Desktop 11 SP3 gwenhywfar Ignore
SUSE Linux Enterprise Desktop 11 SP4 gwenhywfar Ignore
SUSE Linux Enterprise Desktop 12 gwenhywfar Affected
SUSE Linux Enterprise Desktop 12 SP1 gwenhywfar Unsupported
SUSE Linux Enterprise Desktop 12 SP2 gwenhywfar Released
SUSE Linux Enterprise Desktop 12 SP3 gwenhywfar Released
SUSE Linux Enterprise Desktop 12 SP4 gwenhywfar Affected
SUSE Linux Enterprise Server 11 SP3 gwenhywfar Ignore
SUSE Linux Enterprise Server 11 SP4 gwenhywfar Ignore
SUSE Linux Enterprise Server 12 gwenhywfar Affected
SUSE Linux Enterprise Server 12 SP1 gwenhywfar Affected
SUSE Linux Enterprise Server 12 SP2 gwenhywfar Released
SUSE Linux Enterprise Server 12 SP3 gwenhywfar Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 gwenhywfar Ignore
SUSE Linux Enterprise Server for SAP Applications 11 SP4 gwenhywfar Ignore
SUSE Linux Enterprise Server for SAP Applications 12 gwenhywfar Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 gwenhywfar Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 gwenhywfar Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 gwenhywfar Released
SUSE Linux Enterprise Software Development Kit 11 SP3 gwenhywfar Ignore
SUSE Linux Enterprise Software Development Kit 11 SP4 gwenhywfar Ignore
SUSE Linux Enterprise Software Development Kit 12 gwenhywfar Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 gwenhywfar Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 gwenhywfar Released
SUSE Linux Enterprise Software Development Kit 12 SP3 gwenhywfar Released
SUSE Linux Enterprise Software Development Kit 12 SP4 gwenhywfar Affected
SUSE Linux Enterprise Workstation Extension 12 gwenhywfar Affected
SUSE Linux Enterprise Workstation Extension 12 SP1 gwenhywfar Affected
SUSE Linux Enterprise Workstation Extension 12 SP2 gwenhywfar Released
SUSE Linux Enterprise Workstation Extension 12 SP3 gwenhywfar Released
SUSE Linux Enterprise Workstation Extension 12 SP4 gwenhywfar Affected


SUSE Timeline for this CVE

CVE page created: Mon Dec 7 18:15:17 2015
CVE page last modified: Tue Jan 17 13:06:49 2023