Upstream information

CVE-2015-7236 at MITRE

Description

Use-after-free vulnerability in xprt_set_caller in rpcb_svc_com.c in rpcbind 0.2.1 and earlier allows remote attackers to cause a denial of service (daemon crash) via crafted packets, involving a PMAP_CALLIT code.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entries: 940191 [RESOLVED / FIXED], 946204 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 6
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Module for Basesystem 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • rpcbind >= 0.2.3-5.3.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA rpcbind-0.2.3-5.3.1
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Basesystem 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • rpcbind >= 0.2.3-5.9.2
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA rpcbind-0.2.3-5.9.2
SUSE Enterprise Storage 7
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • rpcbind >= 0.2.3-5.9.2
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA rpcbind-0.2.3-5.9.2
SUSE Linux Enterprise Desktop 11 SP3
  • rpcbind >= 0.1.6+git20080930-6.24.1
Patchnames:
sledsp3-rpcbind-12123
SUSE Linux Enterprise Desktop 11 SP4
  • rpcbind >= 0.1.6+git20080930-6.24.1
Patchnames:
sledsp4-rpcbind-12123
SUSE Linux Enterprise Desktop 12 SP1
  • rpcbind >= 0.2.1_rc4-16.2
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA rpcbind-0.2.1_rc4-16.2
SUSE Linux Enterprise Desktop 12 SP2
  • rpcbind >= 0.2.3-21.4
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA rpcbind-0.2.3-21.4
SUSE Linux Enterprise Desktop 12 SP3
  • rpcbind >= 0.2.3-23.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA rpcbind-0.2.3-23.1
SUSE Linux Enterprise Desktop 12 SP4
  • rpcbind >= 0.2.3-23.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA rpcbind-0.2.3-23.1
SUSE Linux Enterprise Desktop 12
  • rpcbind >= 0.2.1_rc4-13.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-2015-659
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • rpcbind >= 0.2.3-5.9.2
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA rpcbind-0.2.3-5.9.2
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • rpcbind >= 0.2.3-3.22
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA rpcbind-0.2.3-3.22
SUSE Linux Enterprise High Performance Computing 12 SP5
  • rpcbind >= 0.2.3-24.9.1
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA rpcbind-0.2.3-24.9.1
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • rpcbind >= 0.1.6+git20080930-6.24.1
Patchnames:
slessp3-rpcbind-12123
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • rpcbind >= 0.1.6+git20080930-6.24.1
Patchnames:
slessp4-rpcbind-12123
SUSE Linux Enterprise Server 12 SP1
  • rpcbind >= 0.2.1_rc4-16.2
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA rpcbind-0.2.1_rc4-16.2
SUSE Linux Enterprise Server 12 SP2
  • rpcbind >= 0.2.3-21.4
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA rpcbind-0.2.3-21.4
SUSE Linux Enterprise Server 12 SP3
  • rpcbind >= 0.2.3-23.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA rpcbind-0.2.3-23.1
SUSE Linux Enterprise Server 12 SP4
  • rpcbind >= 0.2.3-23.1
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA rpcbind-0.2.3-23.1
SUSE Linux Enterprise Server 12 SP5
  • rpcbind >= 0.2.3-24.9.1
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA rpcbind-0.2.3-24.9.1
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server for SAP Applications 12
  • rpcbind >= 0.2.1_rc4-13.3.1
Patchnames:
SUSE-SLE-SERVER-12-2015-659
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • rpcbind >= 0.2.3-21.4
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA rpcbind-0.2.3-21.4
openSUSE Leap 15.0
  • rpcbind >= 0.2.3-lp150.2.7
Patchnames:
openSUSE Leap 15.0 GA rpcbind-0.2.3-lp150.2.7
openSUSE Leap 15.2
  • rpcbind >= 0.2.3-lp152.7.3
Patchnames:
openSUSE Leap 15.2 GA rpcbind-0.2.3-lp152.7.1
openSUSE Leap 15.3
  • rpcbind >= 0.2.3-5.9.2
Patchnames:
openSUSE Leap 15.3 GA rpcbind-0.2.3-5.9.2
openSUSE Leap 15.4
  • rpcbind >= 0.2.3-5.9.2
Patchnames:
openSUSE Leap 15.4 GA rpcbind-0.2.3-5.9.2
openSUSE Tumbleweed
  • rpcbind >= 0.2.3-7.1
Patchnames:
openSUSE Tumbleweed GA rpcbind-0.2.3-7.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise High Performance Computing 12 SP5 rpcbind Already fixed
SUSE Linux Enterprise Server 12 SP5 rpcbind Already fixed
SUSE Linux Enterprise Server 12-LTSS rpcbind Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 rpcbind Already fixed
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Server 12 SP2-BCL rpcbind Already fixed
SUSE Linux Enterprise Server 12 SP4 rpcbind Already fixed
SUSE Linux Enterprise Server 12 SP4-LTSS rpcbind Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP4 rpcbind Already fixed
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 rpcbind Already fixed
SLES for SAP Applications 11 SP2 rpcbind Released
SUSE Linux Enterprise Desktop 11 SP2 rpcbind Released
SUSE Linux Enterprise Desktop 11 SP3 rpcbind Released
SUSE Linux Enterprise Desktop 11 SP4 rpcbind Released
SUSE Linux Enterprise Desktop 12 rpcbind Released
SUSE Linux Enterprise Desktop 12 SP1 rpcbind Already fixed
SUSE Linux Enterprise Desktop 12 SP2 rpcbind Already fixed
SUSE Linux Enterprise Desktop 12 SP3 rpcbind Already fixed
SUSE Linux Enterprise Desktop 12 SP4 rpcbind Already fixed
SUSE Linux Enterprise Server 11 SP2 rpcbind Released
SUSE Linux Enterprise Server 11 SP2 LTSS rpcbind Released
SUSE Linux Enterprise Server 11 SP3 rpcbind Released
SUSE Linux Enterprise Server 11 SP3-LTSS rpcbind Affected
SUSE Linux Enterprise Server 11 SP4 rpcbind Released
SUSE Linux Enterprise Server 11 SP4-LTSS rpcbind Released
SUSE Linux Enterprise Server 12 rpcbind Released
SUSE Linux Enterprise Server 12 SP1 rpcbind Already fixed
SUSE Linux Enterprise Server 12 SP1-LTSS rpcbind Already fixed
SUSE Linux Enterprise Server 12 SP2 rpcbind Already fixed
SUSE Linux Enterprise Server 12 SP2-ESPOS rpcbind Already fixed
SUSE Linux Enterprise Server 12 SP2-LTSS rpcbind Already fixed
SUSE Linux Enterprise Server 12 SP3 rpcbind Already fixed
SUSE Linux Enterprise Server 12 SP3-BCL rpcbind Already fixed
SUSE Linux Enterprise Server 12 SP3-ESPOS rpcbind Already fixed
SUSE Linux Enterprise Server 12 SP3-LTSS rpcbind Already fixed
SUSE Linux Enterprise Server 12 SP4-ESPOS rpcbind Already fixed
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 rpcbind Already fixed
SUSE Linux Enterprise Server for SAP Applications 11 SP3 rpcbind Released
SUSE Linux Enterprise Server for SAP Applications 11 SP4 rpcbind Released
SUSE Linux Enterprise Server for SAP Applications 12 rpcbind Released
SUSE Linux Enterprise Server for SAP Applications 12 SP1 rpcbind Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP2 rpcbind Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP3 rpcbind Already fixed
SUSE OpenStack Cloud 7 rpcbind Already fixed
SUSE OpenStack Cloud 8 rpcbind Already fixed
SUSE OpenStack Cloud 9 rpcbind Already fixed
SUSE OpenStack Cloud Crowbar 8 rpcbind Already fixed
SUSE OpenStack Cloud Crowbar 9 rpcbind Already fixed


SUSE Timeline for this CVE

CVE page created: Thu Sep 17 15:21:20 2015
CVE page last modified: Fri Jan 20 12:45:37 2023