Security update for the Linux Kernel (Live Patch 25 for SLE 12 SP4)

SUSE Security Update: Security update for the Linux Kernel (Live Patch 25 for SLE 12 SP4)
Announcement ID: SUSE-SU-2022:2699-1
Rating: important
References: #1200605 #1201080 #1201517 #1201655 #1201656 #1201657
Cross-References:CVE-2022-1419 CVE-2022-1679 CVE-2022-20141 CVE-2022-26490 CVE-2022-28389 CVE-2022-28390
Affected Products:
  • SUSE Linux Enterprise Live Patching 12-SP4

An update that fixes 6 vulnerabilities is now available.

Description:

This update for the Linux Kernel 4.12.14-95_93 fixes several issues.
The following security issues were fixed:

  • CVE-2022-28389: Fixed a double free in drivers/net/can/usb/mcba_usb.c vulnerability in the Linux kernel. (bnc#1198033)
  • CVE-2022-26490: Fixed a buffer overflow in the st21nfca driver. An attacker with adjacent NFC access could crash the system or corrupt the system memory. (bsc#1196830)
  • CVE-2022-1419: Fixed a concurrency use-after-free in vgem_gem_dumb_create (bsc#1198742).
  • CVE-2022-28390: Fixed a double free in drivers/net/can/usb/ems_usb.c vulnerability in the Linux kernel (bnc#1198031).
  • CVE-2022-1679: Fixed a use-after-free in the Atheros wireless driver in the way a user forces the ath9k_htc_wait_for_target function to fail with some input messages (bsc#1199487).
  • CVE-2022-20141: Fixed a possible use after free due to improper locking in ip_check_mc_rcu() (bsc#1200604).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Live Patching 12-SP4:
    zypper in -t patch SUSE-SLE-Live-Patching-12-SP4-2022-2698=1 SUSE-SLE-Live-Patching-12-SP4-2022-2699=1

Package List:

  • SUSE Linux Enterprise Live Patching 12-SP4 (ppc64le s390x x86_64):
    • kgraft-patch-4_12_14-95_88-default-8-2.2
    • kgraft-patch-4_12_14-95_93-default-7-2.2

References: