Security update for the Linux Kernel (Live Patch 40 for SLE 12 SP3)

SUSE Security Update: Security update for the Linux Kernel (Live Patch 40 for SLE 12 SP3)
Announcement ID: SUSE-SU-2021:3459-1
Rating: important
References: #1187054 #1188613 #1190118 #1190350
Cross-References:CVE-2021-3573 CVE-2021-3640 CVE-2021-3715 CVE-2021-38160
Affected Products:
  • SUSE Linux Enterprise Server for SAP 12-SP3
  • SUSE Linux Enterprise Server 12-SP3-LTSS

An update that fixes four vulnerabilities is now available.

Description:

This update for the Linux Kernel 4.4.180-94_147 fixes several issues.
The following security issues were fixed:

  • CVE-2021-3715: Fixed a user-after-free in the Linux kernel's Traffic Control networking subsystem which could lead to local privilege escalation. (bsc#1190350).
  • CVE-2021-38160: Fixed a bug that could lead to a data corruption or loss. This can be triggered by an untrusted device that supplies a buf->len value exceeding the buffer size in drivers/char/virtio_console.c (bsc#1190118)
  • CVE-2021-3640: Fixed a user-after-free bug in the function sco_sock_sendmsg which could lead to local privilege escalation. (bsc#1188613)
  • CVE-2021-3573: Fixed a user-after-free bug in the function hci_sock_bound_ioctl which could lead to local privilege escalation. (bsc#1187054).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server for SAP 12-SP3:
    zypper in -t patch SUSE-SLE-SAP-12-SP3-2021-3458=1 SUSE-SLE-SAP-12-SP3-2021-3459=1 SUSE-SLE-SAP-12-SP3-2021-3460=1 SUSE-SLE-SAP-12-SP3-2021-3461=1 SUSE-SLE-SAP-12-SP3-2021-3462=1
  • SUSE Linux Enterprise Server 12-SP3-LTSS:
    zypper in -t patch SUSE-SLE-SERVER-12-SP3-2021-3458=1 SUSE-SLE-SERVER-12-SP3-2021-3459=1 SUSE-SLE-SERVER-12-SP3-2021-3460=1 SUSE-SLE-SERVER-12-SP3-2021-3461=1 SUSE-SLE-SERVER-12-SP3-2021-3462=1

Package List:

  • SUSE Linux Enterprise Server for SAP 12-SP3 (ppc64le x86_64):
    • kgraft-patch-4_4_180-94_135-default-13-2.2
    • kgraft-patch-4_4_180-94_135-default-debuginfo-13-2.2
    • kgraft-patch-4_4_180-94_138-default-11-2.2
    • kgraft-patch-4_4_180-94_138-default-debuginfo-11-2.2
    • kgraft-patch-4_4_180-94_141-default-10-2.2
    • kgraft-patch-4_4_180-94_141-default-debuginfo-10-2.2
    • kgraft-patch-4_4_180-94_144-default-7-2.1
    • kgraft-patch-4_4_180-94_144-default-debuginfo-7-2.1
    • kgraft-patch-4_4_180-94_147-default-4-2.1
    • kgraft-patch-4_4_180-94_147-default-debuginfo-4-2.1
  • SUSE Linux Enterprise Server 12-SP3-LTSS (ppc64le x86_64):
    • kgraft-patch-4_4_180-94_135-default-13-2.2
    • kgraft-patch-4_4_180-94_135-default-debuginfo-13-2.2
    • kgraft-patch-4_4_180-94_138-default-11-2.2
    • kgraft-patch-4_4_180-94_138-default-debuginfo-11-2.2
    • kgraft-patch-4_4_180-94_141-default-10-2.2
    • kgraft-patch-4_4_180-94_141-default-debuginfo-10-2.2
    • kgraft-patch-4_4_180-94_144-default-7-2.1
    • kgraft-patch-4_4_180-94_144-default-debuginfo-7-2.1
    • kgraft-patch-4_4_180-94_147-default-4-2.1
    • kgraft-patch-4_4_180-94_147-default-debuginfo-4-2.1

References: