Security update for curl

SUSE Security Update: Security update for curl
Announcement ID: SUSE-SU-2021:2425-1
Rating: moderate
References: #1188217 #1188218 #1188219 #1188220
Cross-References:CVE-2021-22922 CVE-2021-22923 CVE-2021-22924 CVE-2021-22925
Affected Products:
  • SUSE OpenStack Cloud Crowbar 9
  • SUSE OpenStack Cloud 9
  • SUSE Linux Enterprise Server for SAP 12-SP4
  • SUSE Linux Enterprise Server 12-SP4-LTSS

An update that fixes four vulnerabilities is now available.

Description:

This update for curl fixes the following issues:

  • CVE-2021-22925: TELNET stack contents disclosure again. (bsc#1188220)
  • CVE-2021-22924: Bad connection reuse due to flawed path name checks. (bsc#1188219)
  • CVE-2021-22923: Insufficiently Protected Credentials. (bsc#1188218)
  • CVE-2021-22922: Wrong content via metalink not discarded. (bsc#1188217)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE OpenStack Cloud Crowbar 9:
    zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2021-2425=1
  • SUSE OpenStack Cloud 9:
    zypper in -t patch SUSE-OpenStack-Cloud-9-2021-2425=1
  • SUSE Linux Enterprise Server for SAP 12-SP4:
    zypper in -t patch SUSE-SLE-SAP-12-SP4-2021-2425=1
  • SUSE Linux Enterprise Server 12-SP4-LTSS:
    zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2021-2425=1

Package List:

  • SUSE OpenStack Cloud Crowbar 9 (x86_64):
    • curl-7.60.0-4.25.1
    • curl-debuginfo-7.60.0-4.25.1
    • curl-debugsource-7.60.0-4.25.1
    • libcurl4-32bit-7.60.0-4.25.1
    • libcurl4-7.60.0-4.25.1
    • libcurl4-debuginfo-32bit-7.60.0-4.25.1
    • libcurl4-debuginfo-7.60.0-4.25.1
  • SUSE OpenStack Cloud 9 (x86_64):
    • curl-7.60.0-4.25.1
    • curl-debuginfo-7.60.0-4.25.1
    • curl-debugsource-7.60.0-4.25.1
    • libcurl4-32bit-7.60.0-4.25.1
    • libcurl4-7.60.0-4.25.1
    • libcurl4-debuginfo-32bit-7.60.0-4.25.1
    • libcurl4-debuginfo-7.60.0-4.25.1
  • SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64):
    • curl-7.60.0-4.25.1
    • curl-debuginfo-7.60.0-4.25.1
    • curl-debugsource-7.60.0-4.25.1
    • libcurl4-7.60.0-4.25.1
    • libcurl4-debuginfo-7.60.0-4.25.1
  • SUSE Linux Enterprise Server for SAP 12-SP4 (x86_64):
    • libcurl4-32bit-7.60.0-4.25.1
    • libcurl4-debuginfo-32bit-7.60.0-4.25.1
  • SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64):
    • curl-7.60.0-4.25.1
    • curl-debuginfo-7.60.0-4.25.1
    • curl-debugsource-7.60.0-4.25.1
    • libcurl4-7.60.0-4.25.1
    • libcurl4-debuginfo-7.60.0-4.25.1
  • SUSE Linux Enterprise Server 12-SP4-LTSS (s390x x86_64):
    • libcurl4-32bit-7.60.0-4.25.1
    • libcurl4-debuginfo-32bit-7.60.0-4.25.1

References: