Security update for s390-tools

SUSE Security Update: Security update for s390-tools
Announcement ID: SUSE-SU-2021:0776-1
Rating: important
References: #1182777 #1182876 #1183041
Cross-References:CVE-2021-25316
Affected Products:
  • SUSE Linux Enterprise Server 12-SP5

An update that solves one vulnerability and has two fixes is now available.

Description:

This update for s390-tools fixes the following issues:

  • Fixed an issue where IPL was not working when bootloader was installed on a SCSI disk with 4k physical blocksize without using a devicemapper target (bsc#1183041).
  • CVE-2021-25316: Do not use predictable temporary file names (bsc#1182777).
  • Made the name of the temporary configuration file in /tmp/ unpredictable (bsc#1182876).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 12-SP5:
    zypper in -t patch SUSE-SLE-SERVER-12-SP5-2021-776=1

Package List:

  • SUSE Linux Enterprise Server 12-SP5 (s390x):
    • osasnmpd-2.1.0-18.29.1
    • osasnmpd-debuginfo-2.1.0-18.29.1
    • s390-tools-2.1.0-18.29.1
    • s390-tools-debuginfo-2.1.0-18.29.1
    • s390-tools-debugsource-2.1.0-18.29.1
    • s390-tools-hmcdrvfs-2.1.0-18.29.1
    • s390-tools-hmcdrvfs-debuginfo-2.1.0-18.29.1
    • s390-tools-zdsfs-2.1.0-18.29.1
    • s390-tools-zdsfs-debuginfo-2.1.0-18.29.1

References: