Security update for file-roller

SUSE Security Update: Security update for file-roller
Announcement ID: SUSE-SU-2020:1088-1
Rating: low
References: #1151585
Cross-References:CVE-2019-16680
Affected Products:
  • SUSE Linux Enterprise Server 12-SP5
  • SUSE Linux Enterprise Server 12-SP4

An update that fixes one vulnerability is now available.

Description:

This update for file-roller fixes the following issues:

  • CVE-2019-16680: Fixed a path traversal vulnerability which could have allowed an overwriting of a file during extraction (bsc#1151585).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 12-SP5:
    zypper in -t patch SUSE-SLE-SERVER-12-SP5-2020-1088=1
  • SUSE Linux Enterprise Server 12-SP4:
    zypper in -t patch SUSE-SLE-SERVER-12-SP4-2020-1088=1

Package List:

  • SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):
    • file-roller-3.20.3-15.3.25
    • file-roller-debuginfo-3.20.3-15.3.25
    • file-roller-debugsource-3.20.3-15.3.25
    • nautilus-file-roller-3.20.3-15.3.25
    • nautilus-file-roller-debuginfo-3.20.3-15.3.25
  • SUSE Linux Enterprise Server 12-SP5 (noarch):
    • file-roller-lang-3.20.3-15.3.25
  • SUSE Linux Enterprise Server 12-SP4 (aarch64 ppc64le s390x x86_64):
    • file-roller-3.20.3-15.3.25
    • file-roller-debuginfo-3.20.3-15.3.25
    • file-roller-debugsource-3.20.3-15.3.25
    • nautilus-file-roller-3.20.3-15.3.25
    • nautilus-file-roller-debuginfo-3.20.3-15.3.25
  • SUSE Linux Enterprise Server 12-SP4 (noarch):
    • file-roller-lang-3.20.3-15.3.25

References: