Security update for nodejs10

SUSE Security Update: Security update for nodejs10
Announcement ID: SUSE-SU-2020:0063-1
Rating: important
References: #1149792 #1159352 #1159812
Cross-References:CVE-2019-16775 CVE-2019-16776 CVE-2019-16777
Affected Products:
  • SUSE Linux Enterprise Module for Web Scripting 12

An update that fixes three vulnerabilities is now available.

Description:

This update for nodejs10 to version 10.18.0 fixes the following issues:
Security issues fixed:

  • CVE-2019-16777, CVE-2019-16776, CVE-2019-16775: Updated npm to 6.13.4, fixing an arbitrary path overwrite and access via "bin" field (bsc#1159352).
  • Added support for chacha20-poly1305 for Authenticated encryption (AEAD).

Non-security issues fixed:
  • Fix wrong path in gypi files (bsc#1159812)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Web Scripting 12:
    zypper in -t patch SUSE-SLE-Module-Web-Scripting-12-2020-63=1

Package List:

  • SUSE Linux Enterprise Module for Web Scripting 12 (aarch64 ppc64le s390x x86_64):
    • nodejs10-10.18.0-1.15.1
    • nodejs10-debuginfo-10.18.0-1.15.1
    • nodejs10-debugsource-10.18.0-1.15.1
    • nodejs10-devel-10.18.0-1.15.1
    • npm10-10.18.0-1.15.1
  • SUSE Linux Enterprise Module for Web Scripting 12 (noarch):
    • nodejs10-docs-10.18.0-1.15.1

References: