Recommended update for go1.9

SUSE Recommended Update: Recommended update for go1.9
Announcement ID: SUSE-RU-2020:1341-1
Rating: moderate
References: #1082409 #1119634 #1121397 #974800
Affected Products:
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1

An update that has four recommended fixes can now be installed.

Description:

This update for go1.9 fixes the following issues:

  • Fix for bootstrap to work gcc other than gcc9 at armv7l. (bsc#974800)
  • Fix for build failures with gcc7. (bsc#1121397)
  • Set GOPATH automatically and removes go.sh and GOROOT, in order to make switching between versions no longer break. (bsc#1119634)
  • Fix for an issue in build when symlinks pointing to versions that were never installed at all. (bsc#1082409)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-1341=1

Package List:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (aarch64 ppc64le s390x x86_64):
    • go1.9-1.9.7-3.6.2
    • go1.9-doc-1.9.7-3.6.2
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (x86_64):
    • go1.9-race-1.9.7-3.6.2

References: