Recommended update for autoyast2

SUSE Recommended Update: Recommended update for autoyast2
Announcement ID: SUSE-RU-2020:1054-1
Rating: important
References: #1155576 #1156567 #1156905 #1159157 #1167596
Affected Products:
  • SUSE Linux Enterprise Server Installer 12-SP4
  • SUSE Linux Enterprise Server 12-SP4

An update that has 5 recommended fixes can now be installed.

Description:

This update fixes issues for autoyast2 and yast2-schema.
autoyast2:

  • Warn the user if no partition has been found due the given 'skip_list' list. (bsc#1155576)
  • Add YaST-AutoInstSchema 'firstboot.rnc' to the desktop file to avoid error on profile validation during checking autoyast custom scripts. (bsc#1156905)
  • Consider extended partitions when trying to figure out whether the partitioning layout described in the profile fits. (bsc#1156567)
  • Report XML parsing errors instead of just crashing. (bsc#1159157)
  • Fixes an issue where the root partition could not be created as XFS (bsc#1167596)

yast2-schema:
  • Fixes an issue where a newly generated autoyast2 schema could be invalid (bsc#1156905)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server Installer 12-SP4:
    zypper in -t patch SUSE-SLE-SERVER-INSTALLER-12-SP4-2020-1054=1
  • SUSE Linux Enterprise Server 12-SP4:
    zypper in -t patch SUSE-SLE-SERVER-12-SP4-2020-1054=1

Package List:

  • SUSE Linux Enterprise Server Installer 12-SP4 (noarch):
    • autoyast2-3.2.36.6-3.25.3
    • autoyast2-installation-3.2.36.6-3.25.3
  • SUSE Linux Enterprise Server 12-SP4 (aarch64 ppc64le s390x x86_64):
    • yast2-schema-3.2.1-5.3.2
  • SUSE Linux Enterprise Server 12-SP4 (noarch):
    • autoyast2-3.2.36.6-3.25.3
    • autoyast2-installation-3.2.36.6-3.25.3

References: