Recommended update for python-kiwi

SUSE Recommended Update: Recommended update for python-kiwi
Announcement ID: SUSE-RU-2020:0989-1
Rating: moderate
References: #1143454 #1163978 #1164310 #1165578 #1167746
Affected Products:
  • SUSE Linux Enterprise Server 12-SP5
  • SUSE Linux Enterprise Module for Public Cloud 12

An update that has 5 recommended fixes can now be installed.

Description:

This update for python-kiwi fixes the following issues:

  • Fixed result map for OEM pxe install (bsc#1165578)
  • Added SECURE_BOOT parameter for grub2 in efi mode to avoid a potential issue while booting (bsc#1167746)
  • /etc/sysconfig/proxy file was accidentally deleted (bsc#1163978)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 12-SP5:
    zypper in -t patch SUSE-SLE-SERVER-12-SP5-2020-989=1
  • SUSE Linux Enterprise Module for Public Cloud 12:
    zypper in -t patch SUSE-SLE-Module-Public-Cloud-12-2020-989=1

Package List:

  • SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):
    • dracut-kiwi-lib-9.20.5-3.10.2
    • dracut-kiwi-live-9.20.5-3.10.2
    • dracut-kiwi-oem-dump-9.20.5-3.10.2
    • dracut-kiwi-oem-repart-9.20.5-3.10.2
    • dracut-kiwi-overlay-9.20.5-3.10.2
    • kiwi-man-pages-9.20.5-3.10.2
    • kiwi-tools-9.20.5-3.10.2
    • kiwi-tools-debuginfo-9.20.5-3.10.2
    • python-kiwi-debugsource-9.20.5-3.10.2
    • python3-kiwi-9.20.5-3.10.2
    • python3-xattr-0.7.8-4.2.1
  • SUSE Linux Enterprise Server 12-SP5 (noarch):
    • python3-docopt-0.6.2-1.5.1
  • SUSE Linux Enterprise Module for Public Cloud 12 (noarch):
    • python3-docopt-0.6.2-1.5.1

References: