Recommended update for antlr

SUSE Recommended Update: Recommended update for antlr
Announcement ID: SUSE-RU-2020:0982-1
Rating: moderate
References: #1158744
Affected Products:
  • SUSE Linux Enterprise Module for SUSE Manager Server 4.0
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1
  • SUSE Linux Enterprise Module for Development Tools 15-SP1

An update that has one recommended fix can now be installed.

Description:

This update for antlr fixes the following issues:

  • Remove obsolete python2 compat symlinks and avoid build failures. (bsc#1158744)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for SUSE Manager Server 4.0:
    zypper in -t patch SUSE-SLE-Module-SUSE-Manager-Server-4.0-2020-982=1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-982=1
  • SUSE Linux Enterprise Module for Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP1-2020-982=1

Package List:

  • SUSE Linux Enterprise Module for SUSE Manager Server 4.0 (noarch):
    • antlr-java-2.7.7-11.3.4
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (aarch64 ppc64le s390x x86_64):
    • python-antlr-2.7.7-11.3.4
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (noarch):
    • antlr-bootstrap-2.7.7-11.3.4
  • SUSE Linux Enterprise Module for Development Tools 15-SP1 (aarch64 ppc64le s390x x86_64):
    • antlr-2.7.7-11.3.4
    • antlr-devel-2.7.7-11.3.4
  • SUSE Linux Enterprise Module for Development Tools 15-SP1 (noarch):
    • antlr-java-2.7.7-11.3.4
    • antlr-manual-2.7.7-11.3.4

References: