Recommended update for tomcat

SUSE Recommended Update: Recommended update for tomcat
Announcement ID: SUSE-RU-2020:0849-1
Rating: important
References: #1167438
Affected Products:
  • SUSE Linux Enterprise Server for SAP 15
  • SUSE Linux Enterprise Server 15-LTSS
  • SUSE Linux Enterprise High Performance Computing 15-LTSS
  • SUSE Linux Enterprise High Performance Computing 15-ESPOS

An update that has one recommended fix can now be installed.

Description:

This update for tomcat fixes the following issues:

  • Fixes a bug that lead to requests being handled incorrectly, when a CRLF sequence was split between TCP packags (bsc#1167438)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server for SAP 15:
    zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2020-849=1
  • SUSE Linux Enterprise Server 15-LTSS:
    zypper in -t patch SUSE-SLE-Product-SLES-15-2020-849=1
  • SUSE Linux Enterprise High Performance Computing 15-LTSS:
    zypper in -t patch SUSE-SLE-Product-HPC-15-2020-849=1
  • SUSE Linux Enterprise High Performance Computing 15-ESPOS:
    zypper in -t patch SUSE-SLE-Product-HPC-15-2020-849=1

Package List:

  • SUSE Linux Enterprise Server for SAP 15 (noarch):
    • tomcat-9.0.33-3.46.1
    • tomcat-admin-webapps-9.0.33-3.46.1
    • tomcat-el-3_0-api-9.0.33-3.46.1
    • tomcat-jsp-2_3-api-9.0.33-3.46.1
    • tomcat-lib-9.0.33-3.46.1
    • tomcat-servlet-4_0-api-9.0.33-3.46.1
    • tomcat-webapps-9.0.33-3.46.1
  • SUSE Linux Enterprise Server 15-LTSS (noarch):
    • tomcat-9.0.33-3.46.1
    • tomcat-admin-webapps-9.0.33-3.46.1
    • tomcat-el-3_0-api-9.0.33-3.46.1
    • tomcat-jsp-2_3-api-9.0.33-3.46.1
    • tomcat-lib-9.0.33-3.46.1
    • tomcat-servlet-4_0-api-9.0.33-3.46.1
    • tomcat-webapps-9.0.33-3.46.1
  • SUSE Linux Enterprise High Performance Computing 15-LTSS (noarch):
    • tomcat-9.0.33-3.46.1
    • tomcat-admin-webapps-9.0.33-3.46.1
    • tomcat-el-3_0-api-9.0.33-3.46.1
    • tomcat-jsp-2_3-api-9.0.33-3.46.1
    • tomcat-lib-9.0.33-3.46.1
    • tomcat-servlet-4_0-api-9.0.33-3.46.1
    • tomcat-webapps-9.0.33-3.46.1
  • SUSE Linux Enterprise High Performance Computing 15-ESPOS (noarch):
    • tomcat-9.0.33-3.46.1
    • tomcat-admin-webapps-9.0.33-3.46.1
    • tomcat-el-3_0-api-9.0.33-3.46.1
    • tomcat-jsp-2_3-api-9.0.33-3.46.1
    • tomcat-lib-9.0.33-3.46.1
    • tomcat-servlet-4_0-api-9.0.33-3.46.1
    • tomcat-webapps-9.0.33-3.46.1

References: