Recommended update for python-kiwi

SUSE Recommended Update: Recommended update for python-kiwi
Announcement ID: SUSE-RU-2020:0840-1
Rating: moderate
References: #1143454 #1163978 #1164310 #1165578 #1167746
Affected Products:
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1
  • SUSE Linux Enterprise Module for Development Tools 15-SP1

An update that has 5 recommended fixes can now be installed.

Description:

This update for python-kiwi fixes the following issues:

  • Upgrade from version 9.19.8 to 9.20.5

* Fixed result map for OEM pxe install. (bsc#1165578)
* Add SECURE_BOOT parameter for grub2 in efi mode. (bsc#1167746)
This commit adds the SECURE_BOOT parameter on bootloader sysconfig for grub2.
* Fix order in fstab. (bsc#1164310)
Any mount point directly under / should be just right after the root mountpoint and before the custom mountpoints based on user's subvolume configuration.
* Fixed handling of fillup templates. (bsc#1163978)
Systems using a template tool to generate config files might not be effective when they see the intermediate config files we need from the host to let certain package managers work correctly. Therefore the cleanup code in kiwi takes care to restore from an optionally existing template file if no other custom variant is present.
* Start using tftp system user package (bsc#1143454)
This update starts requiring the tftp system user package. This user was created and managed by multiple packages before, with the risk of having inconsistent criteria on its defaults. With the system user package every package that requires this user should just require this package and do not create or modify the tftp user.

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-840=1
  • SUSE Linux Enterprise Module for Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP1-2020-840=1

Package List:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (aarch64 ppc64le s390x x86_64):
    • python-kiwi-debugsource-9.20.5-3.12.2
  • SUSE Linux Enterprise Module for Development Tools 15-SP1 (aarch64 ppc64le s390x x86_64):
    • dracut-kiwi-lib-9.20.5-3.12.2
    • dracut-kiwi-live-9.20.5-3.12.2
    • dracut-kiwi-oem-dump-9.20.5-3.12.2
    • dracut-kiwi-oem-repart-9.20.5-3.12.2
    • dracut-kiwi-overlay-9.20.5-3.12.2
    • kiwi-man-pages-9.20.5-3.12.2
    • kiwi-tools-9.20.5-3.12.2
    • kiwi-tools-debuginfo-9.20.5-3.12.2
    • python-kiwi-debugsource-9.20.5-3.12.2
    • python3-kiwi-9.20.5-3.12.2
  • SUSE Linux Enterprise Module for Development Tools 15-SP1 (x86_64):
    • kiwi-pxeboot-9.20.5-3.12.2

References: