Recommended update for deepsea

SUSE Recommended Update: Recommended update for deepsea
Announcement ID: SUSE-RU-2020:0789-1
Rating: moderate
References: #1154489 #1158184 #1158196 #1160172 #1164571 #1164869
Affected Products:
  • SUSE Enterprise Storage 6

An update that has 6 recommended fixes can now be installed.

Description:

This update for deepsea to version 0.9.28 fixes the following issues:

  • Correct spelling typo (bsc#1154489)
  • Validate iperf results from modules (bsc#1164869)
  • Do not rely on isinstance (bsc#1164571)
  • Create disabled files to simplify removal instructions (SES-769)
  • Grains are not used by ceph-volume (bsc#1160172)
  • cephdisks: exclude mdraid devices (bsc#1158196)
  • Add upgrade check for "straw" algorithm (SES-356)
  • use non-blocking i/o with .wait (bsc#1158184)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Enterprise Storage 6:
    zypper in -t patch SUSE-Storage-6-2020-789=1

Package List:

  • SUSE Enterprise Storage 6 (noarch):
    • deepsea-0.9.28+git.0.cd4c061cd-3.12.1
    • deepsea-cli-0.9.28+git.0.cd4c061cd-3.12.1

References: