Recommended update for osc

SUSE Recommended Update: Recommended update for osc
Announcement ID: SUSE-RU-2020:0627-1
Rating: important
References: #1136584 #1137477 #1154972 #1155953 #1156501
Affected Products:
  • SUSE Linux Enterprise Module for Development Tools 15-SP1

An update that has 5 recommended fixes can now be installed.

Description:

This update for osc fixes the following issues:

  • Fix for 'vc' option '--file=foo bar.changes' now writes the content from foo into bar.changes instead of creating a new file. (bsc#1155953)
  • Fix local build outside of the working copy of a package. (bsc#1136584)
  • Enable not to enforce password reuse. (bsc#1156501)
  • New password handling backend supporting password stores like 'plaintext', 'obfuscated', 'python-keyring' (kwallet, secret store), 'gnome-keyring' or not storing at all. (bsc#1154972)
  • Fix for using non-UTF8 characters in labels. (bsc#1137477)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP1-2020-627=1

Package List:

  • SUSE Linux Enterprise Module for Development Tools 15-SP1 (noarch):
    • osc-0.167.2-3.12.1

References: