Recommended update for yast2-sudo

SUSE Recommended Update: Recommended update for yast2-sudo
Announcement ID: SUSE-RU-2020:0448-1
Rating: moderate
References: #1156929
Affected Products:
  • SUSE Linux Enterprise Server 12-SP5
  • SUSE Linux Enterprise Server 12-SP4
  • SUSE Linux Enterprise Desktop 12-SP4

An update that has one recommended fix can now be installed.

Description:

This update for yast2-sudo fixes the following issues:

  • Prevent truncating the sudoers file after write changes. (bsc#1156929)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 12-SP5:
    zypper in -t patch SUSE-SLE-SERVER-12-SP5-2020-448=1
  • SUSE Linux Enterprise Server 12-SP4:
    zypper in -t patch SUSE-SLE-SERVER-12-SP4-2020-448=1
  • SUSE Linux Enterprise Desktop 12-SP4:
    zypper in -t patch SUSE-SLE-DESKTOP-12-SP4-2020-448=1

Package List:

  • SUSE Linux Enterprise Server 12-SP5 (noarch):
    • yast2-sudo-3.1.3-5.6.1
  • SUSE Linux Enterprise Server 12-SP4 (noarch):
    • yast2-sudo-3.1.3-5.6.1
  • SUSE Linux Enterprise Desktop 12-SP4 (noarch):
    • yast2-sudo-3.1.3-5.6.1

References: