Recommended update for tomcat

SUSE Recommended Update: Recommended update for tomcat
Announcement ID: SUSE-RU-2020:0301-1
Rating: important
References: #1162081
Affected Products:
  • SUSE Linux Enterprise Server for SAP 15
  • SUSE Linux Enterprise Server 15-LTSS
  • SUSE Linux Enterprise Module for Web Scripting 15
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • SUSE Linux Enterprise High Performance Computing 15-LTSS
  • SUSE Linux Enterprise High Performance Computing 15-ESPOS

An update that has one recommended fix can now be installed.

Description:

This update for tomcat fixes the following issue:

  • Fix websocket example code to work properly with Java 1.8. (bsc#1162081)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server for SAP 15:
    zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2020-301=1
  • SUSE Linux Enterprise Server 15-LTSS:
    zypper in -t patch SUSE-SLE-Product-SLES-15-2020-301=1
  • SUSE Linux Enterprise Module for Web Scripting 15:
    zypper in -t patch SUSE-SLE-Module-Web-Scripting-15-2020-301=1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2020-301=1
  • SUSE Linux Enterprise High Performance Computing 15-LTSS:
    zypper in -t patch SUSE-SLE-Product-HPC-15-2020-301=1
  • SUSE Linux Enterprise High Performance Computing 15-ESPOS:
    zypper in -t patch SUSE-SLE-Product-HPC-15-2020-301=1

Package List:

  • SUSE Linux Enterprise Server for SAP 15 (noarch):
    • tomcat-9.0.30-3.37.1
    • tomcat-admin-webapps-9.0.30-3.37.1
    • tomcat-el-3_0-api-9.0.30-3.37.1
    • tomcat-jsp-2_3-api-9.0.30-3.37.1
    • tomcat-lib-9.0.30-3.37.1
    • tomcat-servlet-4_0-api-9.0.30-3.37.1
    • tomcat-webapps-9.0.30-3.37.1
  • SUSE Linux Enterprise Server 15-LTSS (noarch):
    • tomcat-9.0.30-3.37.1
    • tomcat-admin-webapps-9.0.30-3.37.1
    • tomcat-el-3_0-api-9.0.30-3.37.1
    • tomcat-jsp-2_3-api-9.0.30-3.37.1
    • tomcat-lib-9.0.30-3.37.1
    • tomcat-servlet-4_0-api-9.0.30-3.37.1
    • tomcat-webapps-9.0.30-3.37.1
  • SUSE Linux Enterprise Module for Web Scripting 15 (noarch):
    • tomcat-9.0.30-3.37.1
    • tomcat-admin-webapps-9.0.30-3.37.1
    • tomcat-el-3_0-api-9.0.30-3.37.1
    • tomcat-jsp-2_3-api-9.0.30-3.37.1
    • tomcat-lib-9.0.30-3.37.1
    • tomcat-servlet-4_0-api-9.0.30-3.37.1
    • tomcat-webapps-9.0.30-3.37.1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (noarch):
    • tomcat-docs-webapp-9.0.30-3.37.1
    • tomcat-embed-9.0.30-3.37.1
    • tomcat-javadoc-9.0.30-3.37.1
    • tomcat-jsvc-9.0.30-3.37.1
  • SUSE Linux Enterprise High Performance Computing 15-LTSS (noarch):
    • tomcat-9.0.30-3.37.1
    • tomcat-admin-webapps-9.0.30-3.37.1
    • tomcat-el-3_0-api-9.0.30-3.37.1
    • tomcat-jsp-2_3-api-9.0.30-3.37.1
    • tomcat-lib-9.0.30-3.37.1
    • tomcat-servlet-4_0-api-9.0.30-3.37.1
    • tomcat-webapps-9.0.30-3.37.1
  • SUSE Linux Enterprise High Performance Computing 15-ESPOS (noarch):
    • tomcat-9.0.30-3.37.1
    • tomcat-admin-webapps-9.0.30-3.37.1
    • tomcat-el-3_0-api-9.0.30-3.37.1
    • tomcat-jsp-2_3-api-9.0.30-3.37.1
    • tomcat-lib-9.0.30-3.37.1
    • tomcat-servlet-4_0-api-9.0.30-3.37.1
    • tomcat-webapps-9.0.30-3.37.1

References: