Recommended update for suse-migration-services

SUSE Recommended Update: Recommended update for suse-migration-services
Announcement ID: SUSE-RU-2020:0248-1
Rating: moderate
References: #1155192 #1156068
Affected Products:
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1

An update that has two recommended fixes can now be installed.

Description:

This update for suse-migration-services fixes the following issues:

  • Add support for LVM managed storing devices (bsc#1156068) Logical Volume Manager storage requires a service for activate and mount the required volumes. This fix provides the required service.
  • Fix registration checks and migration failure from SLES12-SP4 to SLES15-SP1 (bsc#1155192) Now the migration config file provides a schema validation for checking the config file before executing the migration process. As there could be different targets (SLES, SLES_SAP, etc) instead of setting the target in the custom file, the migration system auto detects the migration product.
  • Update documentation and logs provided by the migration tool

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-248=1

Package List:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (noarch):
    • suse-migration-services-2.0.4-1.12.1

References: