Security update for the Linux Kernel (Live Patch 2 for SLE 12 SP4)

SUSE Security Update: Security update for the Linux Kernel (Live Patch 2 for SLE 12 SP4)
Announcement ID: SUSE-SU-2019:3223-1
Rating: important
References: #1153108 #1156320 #1156321 #1156334
Cross-References: CVE-2018-16871 CVE-2019-10220 CVE-2019-13272 CVE-2019-15917
Affected Products:
  • SUSE Linux Enterprise Live Patching 12-SP4

An update that fixes four vulnerabilities is now available.

Description:

This update for the Linux Kernel 4.12.14-95_6 fixes several issues.
The following security issues were fixed:

  • CVE-2019-15917: Fixed a use-after-free when hci_uart_register_dev() fails in hci_uart_set_proto() (bsc#1156334).
  • CVE-2019-13272: Fixed a privilege escalation from user to root due to improper handling of credentials by leveraging certain scenarios with a parent-child process relationship (bsc#1156321).
  • CVE-2018-16871: Fixed an issue where an attacker, who could mount an exported NFS filesystem, was able to trigger a null pointer dereference by using an invalid NFS sequence leading to kernel panic and deny of access to the NFS server (bsc#1156320).
  • CVE-2019-10220: Fixed an issue where samba servers could inject relative paths in directory entry lists (bsc#1153108).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Live Patching 12-SP4:
    zypper in -t patch SUSE-SLE-Live-Patching-12-SP4-2019-3223=1

Package List:

  • SUSE Linux Enterprise Live Patching 12-SP4 (ppc64le x86_64):
    • kgraft-patch-4_12_14-95_6-default-7-2.5

References: