Security update for strongswan

SUSE Security Update: Security update for strongswan
Announcement ID: SUSE-SU-2019:3056-1
Rating: important
References: #1093536 #1094462 #1107874 #1109845
Cross-References: CVE-2018-10811 CVE-2018-16151 CVE-2018-16152 CVE-2018-17540 CVE-2018-5388
Affected Products:
  • SUSE Linux Enterprise Module for Packagehub Subpackages 15
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • SUSE Linux Enterprise Module for Basesystem 15-SP1
  • SUSE Linux Enterprise Module for Basesystem 15

An update that fixes 5 vulnerabilities is now available.

Description:

This update for strongswan fixes the following issues:
Security issues fixed:

  • CVE-2018-5388: Fixed a buffer underflow which may allow to a remote attacker with local user credentials to resource exhaustion and denial of service while reading from the socket (bsc#1094462).
  • CVE-2018-10811: Fixed a denial of service during the IKEv2 key derivation if the openssl plugin is used in FIPS mode and HMAC-MD5 is negotiated as PRF (bsc#1093536).
  • CVE-2018-16151,CVE-2018-16152: Fixed multiple flaws in the gmp plugin which might lead to authorization bypass (bsc#1107874).
  • CVE-2018-17540: Fixed an improper input validation in gmp plugin (bsc#1109845).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Packagehub Subpackages 15:
    zypper in -t patch SUSE-SLE-Module-Packagehub-Subpackages-15-2019-3056=1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-3056=1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-3056=1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2019-3056=1
  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-3056=1

Package List:

  • SUSE Linux Enterprise Module for Packagehub Subpackages 15 (aarch64 ppc64le s390x x86_64):
    • strongswan-debuginfo-5.6.0-4.3.2
    • strongswan-debugsource-5.6.0-4.3.2
    • strongswan-nm-5.6.0-4.3.2
    • strongswan-nm-debuginfo-5.6.0-4.3.2
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (aarch64 ppc64le s390x x86_64):
    • strongswan-debuginfo-5.6.0-4.3.2
    • strongswan-debugsource-5.6.0-4.3.2
    • strongswan-mysql-5.6.0-4.3.2
    • strongswan-mysql-debuginfo-5.6.0-4.3.2
    • strongswan-nm-5.6.0-4.3.2
    • strongswan-nm-debuginfo-5.6.0-4.3.2
    • strongswan-sqlite-5.6.0-4.3.2
    • strongswan-sqlite-debuginfo-5.6.0-4.3.2
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • strongswan-debuginfo-5.6.0-4.3.2
    • strongswan-debugsource-5.6.0-4.3.2
    • strongswan-mysql-5.6.0-4.3.2
    • strongswan-mysql-debuginfo-5.6.0-4.3.2
    • strongswan-nm-5.6.0-4.3.2
    • strongswan-nm-debuginfo-5.6.0-4.3.2
    • strongswan-sqlite-5.6.0-4.3.2
    • strongswan-sqlite-debuginfo-5.6.0-4.3.2
  • SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x x86_64):
    • strongswan-5.6.0-4.3.2
    • strongswan-debuginfo-5.6.0-4.3.2
    • strongswan-debugsource-5.6.0-4.3.2
    • strongswan-hmac-5.6.0-4.3.2
    • strongswan-ipsec-5.6.0-4.3.2
    • strongswan-ipsec-debuginfo-5.6.0-4.3.2
    • strongswan-libs0-5.6.0-4.3.2
    • strongswan-libs0-debuginfo-5.6.0-4.3.2
  • SUSE Linux Enterprise Module for Basesystem 15-SP1 (noarch):
    • strongswan-doc-5.6.0-4.3.2
  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • strongswan-5.6.0-4.3.2
    • strongswan-debuginfo-5.6.0-4.3.2
    • strongswan-debugsource-5.6.0-4.3.2
    • strongswan-hmac-5.6.0-4.3.2
    • strongswan-ipsec-5.6.0-4.3.2
    • strongswan-ipsec-debuginfo-5.6.0-4.3.2
    • strongswan-libs0-5.6.0-4.3.2
    • strongswan-libs0-debuginfo-5.6.0-4.3.2
  • SUSE Linux Enterprise Module for Basesystem 15 (noarch):
    • strongswan-doc-5.6.0-4.3.2

References: