Security update for libtomcrypt

SUSE Security Update: Security update for libtomcrypt
Announcement ID: SUSE-SU-2019:2808-1
Rating: moderate
References: #1153433
Cross-References: CVE-2019-17362
Affected Products:
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15

An update that fixes one vulnerability is now available.

Description:

This update for libtomcrypt fixes the following issue:
CVE-2019-17362: Fixed an improper detection of invalid UTF-8 sequences that could have led to DoS or information disclosure via crafted DER-encoded data (bsc#1153433).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2808=1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-2808=1

Package List:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (aarch64 ppc64le s390x x86_64):
    • libtomcrypt-debugsource-1.17-3.3.1
    • libtomcrypt-devel-1.17-3.3.1
    • libtomcrypt-examples-1.17-3.3.1
    • libtomcrypt0-1.17-3.3.1
    • libtomcrypt0-debuginfo-1.17-3.3.1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • libtomcrypt-debugsource-1.17-3.3.1
    • libtomcrypt-devel-1.17-3.3.1
    • libtomcrypt-examples-1.17-3.3.1
    • libtomcrypt0-1.17-3.3.1
    • libtomcrypt0-debuginfo-1.17-3.3.1

References: