Security update for kubernetes, patchinfo

SUSE Security Update: Security update for kubernetes, patchinfo
Announcement ID: SUSE-SU-2019:2617-1
Rating: moderate
References: #1131001 #1147142
Cross-References: CVE-2019-9512 CVE-2019-9514
Affected Products:
  • SUSE CaaS Platform 3.0

An update that fixes two vulnerabilities is now available.

Description:

This update for kubernetes, patchinfo fixes the following issues:
Security issues fixed:

  • CVE-2019-9512: Fixed HTTP/2 reset flood vulnerability. (bsc#1147142)
  • CVE-2019-9514: Fixed HTTP/2 ping frame flood vulnerability. (bsc#1147142)

Non-security issue fixed:
  • Added ipset package dependency for kube-proxy. (bsc#1131001)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE CaaS Platform 3.0:
    To install this update, use the SUSE CaaS Platform Velum dashboard. It will inform you if it detects new updates and let you then trigger updating of the complete cluster in a controlled way.

Package List:

  • SUSE CaaS Platform 3.0 (x86_64):
    • kubernetes-client-1.10.11-4.14.1
    • kubernetes-common-1.10.11-4.14.1
    • kubernetes-kubelet-1.10.11-4.14.1
    • kubernetes-master-1.10.11-4.14.1
    • kubernetes-node-1.10.11-4.14.1

References: